Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame^] | 1 | SECTION = "devel" |
| 2 | SUMMARY = "Linux Trace Toolkit Control" |
| 3 | DESCRIPTION = "The Linux trace toolkit is a suite of tools designed \ |
| 4 | to extract program execution details from the Linux operating system \ |
| 5 | and interpret them." |
| 6 | |
| 7 | LICENSE = "GPLv2 & LGPLv2.1" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=01d7fc4496aacf37d90df90b90b0cac1 \ |
| 9 | file://gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 10 | file://lgpl-2.1.txt;md5=0f0d71500e6a57fd24d825f33242b9ca" |
| 11 | |
| 12 | DEPENDS = "liburcu popt libxml2 util-linux" |
| 13 | RDEPENDS_${PN} = "libgcc" |
| 14 | RDEPENDS_${PN}-ptest += "make perl bash gawk ${PN} babeltrace procps perl-module-overloading coreutils util-linux kmod" |
| 15 | RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-utils" |
| 16 | RDEPENDS_${PN}-ptest_append_libc-musl = " musl-utils" |
| 17 | # babelstats.pl wants getopt-long |
| 18 | RDEPENDS_${PN}-ptest += "perl-module-getopt-long" |
| 19 | |
| 20 | PYTHON_OPTION = "am_cv_python_pyexecdir='${PYTHON_SITEPACKAGES_DIR}' \ |
| 21 | am_cv_python_pythondir='${PYTHON_SITEPACKAGES_DIR}' \ |
| 22 | PYTHON_INCLUDE='-I${STAGING_INCDIR}/python${PYTHON_BASEVERSION}${PYTHON_ABI}' \ |
| 23 | " |
| 24 | PACKAGECONFIG ??= "lttng-ust" |
| 25 | PACKAGECONFIG[python] = "--enable-python-bindings ${PYTHON_OPTION},,python3 swig-native" |
| 26 | PACKAGECONFIG[lttng-ust] = "--with-lttng-ust, --without-lttng-ust, lttng-ust" |
| 27 | PACKAGECONFIG[kmod] = "--with-kmod, --without-kmod, kmod" |
| 28 | PACKAGECONFIG[manpages] = "--enable-man-pages, --disable-man-pages, asciidoc-native xmlto-native libxslt-native" |
| 29 | PACKAGECONFIG_remove_arc = "lttng-ust" |
| 30 | |
| 31 | SRC_URI = "https://lttng.org/files/lttng-tools/lttng-tools-${PV}.tar.bz2 \ |
| 32 | file://x32.patch \ |
| 33 | file://run-ptest \ |
| 34 | file://lttng-sessiond.service \ |
| 35 | file://0001-Fix-tests-link-libpause_consumer-on-liblttng-ctl.patch \ |
| 36 | file://0002-Fix-test-skip-test_getcpu_override-on-single-thread-.patch \ |
| 37 | file://0003-Fix-test-unit-the-tree-origin-can-be-a-symlink-itsel.patch \ |
| 38 | file://0004-Skip-when-testapp-is-not-present.patch\ |
| 39 | file://0005-Tests-use-modprobe-to-test-for-the-presence-of-lttng.patch \ |
| 40 | file://0006-Tests-check-for-lttng-modules-presence.patch \ |
| 41 | file://0007-Fix-getgrnam-is-not-MT-Safe-use-getgrnam_r.patch \ |
| 42 | " |
| 43 | |
| 44 | SRC_URI[md5sum] = "e88c521b5da6bb48a8187af633336ecc" |
| 45 | SRC_URI[sha256sum] = "f05df52bbebf8ce88d1b29e9e98cfc957d2ed738a345118018237ebdb581537c" |
| 46 | |
| 47 | inherit autotools ptest pkgconfig useradd python3-dir manpages systemd |
| 48 | |
| 49 | SYSTEMD_SERVICE_${PN} = "lttng-sessiond.service" |
| 50 | SYSTEMD_AUTO_ENABLE = "disable" |
| 51 | |
| 52 | USERADD_PACKAGES = "${PN}" |
| 53 | GROUPADD_PARAM_${PN} = "tracing" |
| 54 | |
| 55 | FILES_${PN} += "${libdir}/lttng/libexec/* ${datadir}/xml/lttng \ |
| 56 | ${PYTHON_SITEPACKAGES_DIR}/*" |
| 57 | FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*.a" |
| 58 | FILES_${PN}-dev += "${PYTHON_SITEPACKAGES_DIR}/*.la" |
| 59 | |
| 60 | # Since files are installed into ${libdir}/lttng/libexec we match |
| 61 | # the libexec insane test so skip it. |
| 62 | # Python module needs to keep _lttng.so |
| 63 | INSANE_SKIP_${PN} = "libexec dev-so" |
| 64 | INSANE_SKIP_${PN}-dbg = "libexec" |
| 65 | |
| 66 | do_install_append () { |
| 67 | # install systemd unit file |
| 68 | install -d ${D}${systemd_unitdir}/system |
| 69 | install -m 0644 ${WORKDIR}/lttng-sessiond.service ${D}${systemd_unitdir}/system |
| 70 | } |
| 71 | |
| 72 | do_install_ptest () { |
| 73 | for f in Makefile tests/Makefile tests/utils/utils.sh tests/regression/tools/save-load/load-42*.lttng tests/regression/tools/save-load/configuration/load-42*.lttng ; do |
| 74 | install -D "${B}/$f" "${D}${PTEST_PATH}/$f" |
| 75 | done |
| 76 | |
| 77 | for f in config/tap-driver.sh config/test-driver src/common/config/session.xsd src/common/mi-lttng-3.0.xsd; do |
| 78 | install -D "${S}/$f" "${D}${PTEST_PATH}/$f" |
| 79 | done |
| 80 | |
| 81 | # Prevent 'make check' from recursing into non-test subdirectories. |
| 82 | sed -i -e 's!^SUBDIRS = .*!SUBDIRS = tests!' "${D}${PTEST_PATH}/Makefile" |
| 83 | |
| 84 | # We don't need these |
| 85 | sed -i -e '/dist_noinst_SCRIPTS = /,/^$/d' "${D}${PTEST_PATH}/tests/Makefile" |
| 86 | |
| 87 | # We shouldn't need to build anything in tests/utils |
| 88 | sed -i -e 's!am__append_1 = . utils!am__append_1 = . !' \ |
| 89 | "${D}${PTEST_PATH}/tests/Makefile" |
| 90 | |
| 91 | # Copy the tests directory tree and the executables and |
| 92 | # Makefiles found within. |
| 93 | for d in $(find "${B}/tests" -type d -not -name .libs -printf '%P ') ; do |
| 94 | install -d "${D}${PTEST_PATH}/tests/$d" |
| 95 | find "${B}/tests/$d" -maxdepth 1 -executable -type f \ |
| 96 | -exec install -t "${D}${PTEST_PATH}/tests/$d" {} + |
| 97 | # Take all .py scripts for tests using the python bindings. |
| 98 | find "${B}/tests/$d" -maxdepth 1 -type f -name "*.py" \ |
| 99 | -exec install -t "${D}${PTEST_PATH}/tests/$d" {} + |
| 100 | test -r "${B}/tests/$d/Makefile" && \ |
| 101 | install -t "${D}${PTEST_PATH}/tests/$d" "${B}/tests/$d/Makefile" |
| 102 | done |
| 103 | |
| 104 | for d in $(find "${B}/tests" -type d -name .libs -printf '%P ') ; do |
| 105 | for f in $(find "${B}/tests/$d" -maxdepth 1 -executable -type f -printf '%P ') ; do |
| 106 | cp ${B}/tests/$d/$f ${D}${PTEST_PATH}/tests/`dirname $d`/$f |
| 107 | case $f in |
| 108 | *.so) |
| 109 | install -d ${D}${PTEST_PATH}/tests/$d/ |
| 110 | ln -s ../$f ${D}${PTEST_PATH}/tests/$d/$f |
| 111 | # Remove any rpath/runpath to pass QA check. |
| 112 | chrpath --delete ${D}${PTEST_PATH}/tests/$d/$f |
| 113 | ;; |
| 114 | esac |
| 115 | done |
| 116 | done |
| 117 | |
| 118 | # |
| 119 | # Use the versioned libs of liblttng-ust-dl. |
| 120 | # |
| 121 | ustdl="${D}${PTEST_PATH}/tests/regression/ust/ust-dl/test_ust-dl.py" |
| 122 | if [ -e $ustdl ]; then |
| 123 | sed -i -e 's!:liblttng-ust-dl.so!:liblttng-ust-dl.so.0!' $ustdl |
| 124 | fi |
| 125 | |
| 126 | install ${B}/tests/unit/ini_config/sample.ini ${D}${PTEST_PATH}/tests/unit/ini_config/ |
| 127 | |
| 128 | # We shouldn't need to build anything in tests/regression/tools |
| 129 | sed -i -e 's!^SUBDIRS = tools !SUBDIRS = !' \ |
| 130 | "${D}${PTEST_PATH}/tests/regression/Makefile" |
| 131 | |
| 132 | # Prevent attempts to update Makefiles during test runs, and |
| 133 | # silence "Making check in $SUBDIR" messages. |
| 134 | find "${D}${PTEST_PATH}" -name Makefile -type f -exec \ |
| 135 | sed -i -e '/Makefile:/,/^$/d' -e '/%: %.in/,/^$/d' \ |
| 136 | -e '/echo "Making $$target in $$subdir"; \\/d' \ |
| 137 | -e 's/^srcdir = \(.*\)/srcdir = ./' \ |
| 138 | -e 's/^builddir = \(.*\)/builddir = ./' \ |
| 139 | -e 's/^all-am:.*/all-am:/' \ |
| 140 | {} + |
| 141 | |
| 142 | find "${D}${PTEST_PATH}" -name Makefile -type f -exec \ |
| 143 | touch -r "${B}/Makefile" {} + |
| 144 | |
| 145 | # |
| 146 | # Need to stop generated binaries from rebuilding by removing their source dependencies |
| 147 | # |
| 148 | sed -e 's#\(^test.*OBJECTS.=\)#disable\1#g' \ |
| 149 | -e 's#\(^test.*DEPENDENCIES.=\)#disable\1#g' \ |
| 150 | -e 's#\(^test.*SOURCES.=\)#disable\1#g' \ |
| 151 | -e 's#\(^test.*LDADD.=\)#disable\1#g' \ |
| 152 | -i ${D}${PTEST_PATH}/tests/unit/Makefile |
| 153 | |
| 154 | # Substitute links to installed binaries. |
| 155 | for prog in lttng lttng-relayd lttng-sessiond lttng-consumerd lttng-crash; do |
| 156 | exedir="${D}${PTEST_PATH}/src/bin/${prog}" |
| 157 | install -d "$exedir" |
| 158 | case "$prog" in |
| 159 | lttng-consumerd) |
| 160 | ln -s "${libdir}/lttng/libexec/$prog" "$exedir" |
| 161 | ;; |
| 162 | *) |
| 163 | ln -s "${bindir}/$prog" "$exedir" |
| 164 | ;; |
| 165 | esac |
| 166 | done |
| 167 | } |