Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame^] | 1 | SUMMARY = "A C program to run all installed ptests" |
| 2 | DESCRIPTION = "The ptest-runner2 package installs a ptest-runner \ |
| 3 | program which loops through all installed ptest test suites and \ |
| 4 | runs them in sequence." |
| 5 | HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/ptest-runner2/about/" |
| 6 | |
| 7 | LICENSE = "GPLv2" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe" |
| 9 | |
| 10 | SRCREV = "05b112bda7ac2adba8e9b0f088d6e5843b148a38" |
| 11 | PV = "2.3.1+git${SRCPV}" |
| 12 | |
| 13 | SRC_URI = "git://git.yoctoproject.org/ptest-runner2" |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | FILES_${PN} = "${bindir}/ptest-runner" |
| 17 | |
| 18 | EXTRA_OEMAKE = "-e MAKEFLAGS= CFLAGS="${CFLAGS} -DDEFAULT_DIRECTORY=\\\"${libdir}\\\""" |
| 19 | |
| 20 | do_compile () { |
| 21 | oe_runmake |
| 22 | } |
| 23 | |
| 24 | do_install () { |
| 25 | install -D -m 0755 ${S}/ptest-runner ${D}${bindir}/ptest-runner |
| 26 | } |