Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "DJB daemontools" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 2 | HOMEPAGE = "http://cr.yp.to/daemontools.html" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 3 | DESCRIPTION = "supervise monitors a service. It starts the service and restarts the \ |
| 4 | service if it dies. The companion svc program stops, pauses, or restarts \ |
| 5 | the service on sysadmin request. The svstat program prints a one-line \ |
| 6 | status report. \ |
| 7 | multilog saves error messages to one or more logs. It optionally timestamps \ |
| 8 | each line and, for each log, includes or excludes lines matching specified \ |
| 9 | patterns. It automatically rotates logs to limit the amount of disk space \ |
| 10 | used. If the disk fills up, it pauses and tries again, without losing any \ |
| 11 | data." |
| 12 | |
| 13 | SECTION = "System/Servers" |
| 14 | |
Brad Bishop | 0f291cc | 2019-09-01 15:16:57 -0400 | [diff] [blame] | 15 | LIC_FILES_CHKSUM = "file://src/prot.c;beginline=1;endline=1;md5=96964cadf07e8f8c1e2ffb3b507dd647" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 16 | LICENSE = "PD" |
| 17 | |
| 18 | SRC_URI = "http://cr.yp.to/daemontools/${BPN}-${PV}.tar.gz \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 19 | file://0001-error.h-include-errno.h-instead-of-extern-int.diff \ |
| 20 | file://0002-supervise.c-.-supervise-may-be-a-symlink-if-it-s-da.diff \ |
| 21 | file://cross-compile.patch \ |
| 22 | file://0001-daemontools-Fix-QA-Issue.patch \ |
| 23 | " |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 24 | |
| 25 | SRC_URI[md5sum] = "1871af2453d6e464034968a0fbcb2bfc" |
| 26 | SRC_URI[sha256sum] = "a55535012b2be7a52dcd9eccabb9a198b13be50d0384143bd3b32b8710df4c1f" |
| 27 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 28 | S = "${WORKDIR}/admin/${BP}" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 29 | |
| 30 | do_compile() { |
| 31 | ./package/compile |
| 32 | } |
| 33 | |
| 34 | do_install() { |
| 35 | install -d ${D}/${bindir} |
| 36 | } |
| 37 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 38 | do_install:append:class-target() { |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 39 | install -m755 ${S}/command/* ${D}/${bindir} |
| 40 | } |
| 41 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 42 | inherit update-alternatives |
| 43 | ALTERNATIVE_PRIORITY = "100" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 44 | ALTERNATIVE:${PN} = "svc svok" |