Willy Tu | b7f2207 | 2021-06-24 17:59:46 -0700 | [diff] [blame] | 1 | python() { |
| 2 | # Instead of using BB_ENV_EXTRAWHITE, we can get info from the |
| 3 | # shell environment this way. |
| 4 | origenv = d.getVar("BB_ORIGENV", False) |
| 5 | memo = origenv.getVar("BUILD_MEMO", False) |
| 6 | if memo: |
Willy Tu | a430033 | 2021-06-29 14:17:44 -0700 | [diff] [blame] | 7 | d.setVar("BUILD_MEMO", memo) |
Willy Tu | b7f2207 | 2021-06-24 17:59:46 -0700 | [diff] [blame] | 8 | } |
| 9 | |
Willy Tu | a971dac | 2021-10-01 16:56:41 -0700 | [diff] [blame] | 10 | IMAGE_TYPE = "${GBMC_CONFIG}" |
Brian Ma | 199901b | 2021-12-21 17:15:58 +0800 | [diff] [blame^] | 11 | OS_RELEASE_FIELDS:append:gbmc = " BUILD_MEMO IMAGE_TYPE" |