Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame^] | 1 | SUMMARY = "X screen saver and locker" |
| 2 | |
| 3 | LICENSE = "BSD" |
| 4 | LIC_FILES_CHKSUM = "file://driver/xscreensaver.h;endline=10;md5=e141ab5822fb2d43694e1e47b59fc0df" |
| 5 | |
| 6 | SRC_URI = "https://www.jwz.org/${BPN}/${BP}.tar.gz" |
| 7 | SRC_URI[md5sum] = "a5da62b91271f4e8afcc73d44697364b" |
| 8 | SRC_URI[sha256sum] = "48ce1880f18b5321182be0c033aeceb5ec5628a1505b9d1ff69dbf06093c2426" |
| 9 | |
| 10 | SRC_URI += " \ |
| 11 | file://xscreensaver.service \ |
| 12 | file://fix-buildscripts.patch \ |
| 13 | file://tweak-app-defaults.patch \ |
| 14 | " |
| 15 | |
| 16 | DEPENDS = "intltool-native libx11 libxext libxt libxft glib-2.0-native bc-native" |
| 17 | # These are only needed as part of the stopgap screensaver implementation: |
| 18 | RDEPENDS_${PN} += "xserver-nodm-init liberation-fonts" |
| 19 | |
| 20 | inherit systemd perlnative pkgconfig gettext autotools-brokensep distro_features_check |
| 21 | |
| 22 | REQUIRED_DISTRO_FEATURES = "x11" |
| 23 | |
| 24 | do_install_append() { |
| 25 | install -D ${WORKDIR}/xscreensaver.service ${D}${systemd_unitdir}/system/xscreensaver.service |
| 26 | } |
| 27 | |
| 28 | FILES_${PN} += "${datadir}/X11/app-defaults/XScreenSaver" |
| 29 | SYSTEMD_SERVICE_${PN} = "xscreensaver.service" |