Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "An implementation of the GEIS interface" |
| 2 | DESCRIPTION = "An implementation of the GEIS (Gesture Engine Interface and Support) \ |
| 3 | interface\ |
| 4 | GEIS is a library for applications and toolkit programmers which \ |
| 5 | provides a consistent platform independent interface for any \ |
| 6 | system-wide input gesture recognition mechanism." |
| 7 | |
| 8 | HOMEPAGE = "https://launchpad.net/geis" |
| 9 | |
| 10 | LICENSE = "GPLv3 & LGPLv3" |
| 11 | LIC_FILES_CHKSUM = " \ |
| 12 | file://COPYING;md5=6a6a8e020838b23406c81b19c1d46df6 \ |
| 13 | file://COPYING.GPL;md5=f27defe1e96c2e1ecd4e0c9be8967949 \ |
| 14 | " |
| 15 | |
| 16 | inherit autotools pkgconfig python3native lib_package distro_features_check |
| 17 | |
| 18 | REQUIRED_DISTRO_FEATURES = "x11" |
| 19 | |
| 20 | DEPENDS += "grail dbus-glib python3 virtual/libx11 libxext libxi libxcb dbus frame" |
| 21 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 22 | SRC_URI = "https://launchpad.net/${BPN}/trunk/${PV}/+download/${BPN}-${PV}.tar.xz \ |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 23 | file://fix-indentation-for-gcc6.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 24 | file://0001-libgeis-Compare-the-first-character-of-string-to-nul.patch \ |
| 25 | " |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 26 | SRC_URI[md5sum] = "2ff9d76a3ea5794516bb02c9d1924faf" |
| 27 | SRC_URI[sha256sum] = "8a60f5683852094038904e690d23cc5a90a980fc52da67f0f28890baa25c70eb" |
| 28 | |
| 29 | EXTRA_OECONF = "--disable-integration-tests" |
| 30 | |
| 31 | FILES_${PN}-bin = "${bindir}" |
| 32 | RDEPENDS_${PN}-bin = " \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 33 | python3-compression \ |
| 34 | python3-core \ |
| 35 | python3-crypt \ |
| 36 | python3-ctypes \ |
| 37 | python3-fcntl \ |
| 38 | python3-misc \ |
| 39 | python3-pickle \ |
| 40 | python3-shell \ |
| 41 | python3-stringold \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 42 | python3-threading \ |
| 43 | " |
| 44 | |
| 45 | FILES_${PN} += " \ |
| 46 | ${datadir}/geisview \ |
| 47 | ${libdir}/${PYTHON_DIR}/site-packages/geis* \ |
| 48 | ${libdir}/${PYTHON_DIR}/site-packages/_*.so \ |
| 49 | " |
| 50 | |
| 51 | FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/.debug" |
| 52 | |
| 53 | FILES_${PN}-dev += "${libdir}/${PYTHON_DIR}/site-packages/_*.la" |
| 54 | |
| 55 | FILES_${PN}-staticdev += "${libdir}/${PYTHON_DIR}/site-packages/_*.a" |