Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Set of i2c tools for linux" |
| 2 | HOMEPAGE = "https://i2c.wiki.kernel.org/index.php/I2C_Tools" |
| 3 | SECTION = "base" |
| 4 | LICENSE = "GPLv2+" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 6 | |
| 7 | SRC_URI = "${KERNELORG_MIRROR}/software/utils/i2c-tools/${BP}.tar.gz \ |
| 8 | file://0001-lib-Module.mk-Add-missing-dependencies.patch \ |
| 9 | file://0001-tools-Module.mk-Add-missing-dependencies.patch \ |
| 10 | file://0001-i2c-tools-eeprog-Module.mk-Add-missing-dependency.patch \ |
| 11 | file://remove-i2c-dev.patch \ |
| 12 | " |
| 13 | |
| 14 | SRC_URI[md5sum] = "d92a288d70f306d3895e3a7e9c14c9aa" |
| 15 | SRC_URI[sha256sum] = "5b60daf6f011de0acb61de57dba62f2054bb39f19961d67e0c91610f071ca403" |
| 16 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame^] | 17 | inherit update-alternatives |
| 18 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 19 | EXTRA_OEMAKE = "bindir=${bindir} sbindir=${sbindir} \ |
| 20 | incdir=${includedir} libdir=${libdir} \ |
| 21 | mandir=${mandir} \ |
| 22 | EXTRA=eeprog" |
| 23 | |
| 24 | do_install() { |
| 25 | oe_runmake 'DESTDIR=${D}' install |
| 26 | } |
| 27 | |
| 28 | PACKAGES =+ "${PN}-misc" |
| 29 | FILES_${PN}-misc = "${sbindir}/i2c-stub-from-dump \ |
| 30 | ${bindir}/ddcmon \ |
| 31 | ${bindir}/decode-edid \ |
| 32 | ${bindir}/decode-dimms \ |
| 33 | ${bindir}/decode-vaio \ |
| 34 | " |
| 35 | RDEPENDS_${PN}-misc = "${PN} perl perl-module-posix \ |
| 36 | perl-module-constant perl-module-file-basename \ |
| 37 | perl-module-fcntl perl-module-strict perl-module-vars \ |
| 38 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame^] | 39 | |
| 40 | ALTERNATIVE_PRIORITY = "100" |
| 41 | ALTERNATIVE_${PN} = "i2cdetect i2cdump i2cget i2cset" |
| 42 | ALTERNATIVE_LINK_NAME[i2cdetect] = "${sbindir}/i2cdetect" |
| 43 | ALTERNATIVE_LINK_NAME[i2cdump] = "${sbindir}/i2cdump" |
| 44 | ALTERNATIVE_LINK_NAME[i2cget] = "${sbindir}/i2cget" |
| 45 | ALTERNATIVE_LINK_NAME[i2cset] = "${sbindir}/i2cset" |