Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame^] | 1 | SUMMARY = "Utilities for managing LZMA compressed files" |
| 2 | HOMEPAGE = "http://tukaani.org/xz/" |
| 3 | SECTION = "base" |
| 4 | |
| 5 | # The source includes bits of PD, GPLv2, GPLv3, LGPLv2.1+, but the only file |
| 6 | # which is GPLv3 is an m4 macro which isn't shipped in any of our packages, |
| 7 | # and the LGPL bits are under lib/, which appears to be used for libgnu, which |
| 8 | # appears to be used for DOS builds. So we're left with GPLv2+ and PD. |
| 9 | LICENSE = "GPLv2+ & GPL-3.0-with-autoconf-exception & LGPLv2.1+ & PD" |
| 10 | LICENSE_${PN} = "GPLv2+" |
| 11 | LICENSE_${PN}-dev = "GPLv2+" |
| 12 | LICENSE_${PN}-staticdev = "GPLv2+" |
| 13 | LICENSE_${PN}-doc = "GPLv2+" |
| 14 | LICENSE_${PN}-dbg = "GPLv2+" |
| 15 | LICENSE_${PN}-locale = "GPLv2+" |
| 16 | LICENSE_liblzma = "PD" |
| 17 | |
| 18 | LIC_FILES_CHKSUM = "file://COPYING;md5=97d554a32881fee0aa283d96e47cb24a \ |
| 19 | file://COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 20 | file://COPYING.GPLv3;md5=d32239bcb673463ab874e80d47fae504 \ |
| 21 | file://COPYING.LGPLv2.1;md5=4fbd65380cdd255951079008b364516c \ |
| 22 | file://lib/getopt.c;endline=23;md5=2069b0ee710572c03bb3114e4532cd84 \ |
| 23 | " |
| 24 | |
| 25 | SRC_URI = "http://tukaani.org/xz/xz-${PV}.tar.gz" |
| 26 | SRC_URI[md5sum] = "5ace3264bdd00c65eeec2891346f65e6" |
| 27 | SRC_URI[sha256sum] = "b512f3b726d3b37b6dc4c8570e137b9311e7552e8ccbab4d39d47ce5f4177145" |
| 28 | UPSTREAM_CHECK_REGEX = "xz-(?P<pver>\d+(\.\d+)+)\.tar" |
| 29 | |
| 30 | inherit autotools gettext |
| 31 | |
| 32 | PACKAGES =+ "liblzma" |
| 33 | |
| 34 | FILES_liblzma = "${libdir}/liblzma*${SOLIBS}" |
| 35 | |
| 36 | inherit update-alternatives |
| 37 | ALTERNATIVE_PRIORITY = "100" |
| 38 | ALTERNATIVE_${PN} = "xz xzcat unxz \ |
| 39 | lzma lzcat unlzma" |
| 40 | |
| 41 | BBCLASSEXTEND = "native nativesdk" |
| 42 | |
| 43 | export CONFIG_SHELL="/bin/sh" |