Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "A library for applications dealing with netlink sockets" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "The libnl suite is a collection of libraries providing \ |
| 3 | APIs to netlink protocol based Linux kernel interfaces. libnl is the core \ |
| 4 | library implementing the fundamentals required to use the netlink protocol \ |
| 5 | such as socket handling, message construction and parsing, and sending \ |
| 6 | and receiving of data." |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 7 | HOMEPAGE = "http://www.infradead.org/~tgr/libnl/" |
| 8 | SECTION = "libs/network" |
| 9 | |
| 10 | PE = "1" |
| 11 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 12 | LICENSE = "LGPL-2.1-only" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 13 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" |
| 14 | |
| 15 | DEPENDS = "flex-native bison-native" |
| 16 | |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 17 | SRC_URI = "${GITHUB_BASE_URI}/download/${BPN}${@d.getVar('PV').replace('.','_')}/${BP}.tar.gz \ |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 18 | file://run-ptest \ |
Patrick Williams | db4c27e | 2022-08-05 08:10:29 -0500 | [diff] [blame] | 19 | " |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 20 | |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 21 | SRC_URI[sha256sum] = "aed507004d728a5cf11eab48ca4bf9e6e1874444e33939b9d3dfed25018ee9bb" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 22 | |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 23 | GITHUB_BASE_URI = "https://github.com/thom311/${BPN}/releases" |
| 24 | UPSTREAM_CHECK_REGEX = "releases/tag/libnl(?P<pver>.+)" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 25 | |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 26 | inherit autotools pkgconfig ptest github-releases |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 27 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 28 | FILES:${PN} = "${libdir}/libnl-3.so.* \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 29 | ${libdir}/libnl.so.* \ |
| 30 | ${sysconfdir}" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 31 | RREPLACES:${PN} = "libnl2" |
| 32 | RCONFLICTS:${PN} = "libnl2" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 33 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 34 | FILES:${PN}-dev += "${libdir}/libnl/cli/*/*.la" |
| 35 | FILES:${PN}-staticdev += "${libdir}/libnl/cli/*/*.a" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 36 | |
| 37 | PACKAGES += "${PN}-cli ${PN}-genl ${PN}-idiag ${PN}-nf ${PN}-route ${PN}-xfrm" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 38 | FILES:${PN}-cli = "${libdir}/libnl-cli-3.so.* \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 39 | ${libdir}/libnl/cli/*/*.so \ |
| 40 | ${bindir}/genl-ctrl-list \ |
| 41 | ${bindir}/idiag-socket-details \ |
| 42 | ${bindir}/nf-* \ |
| 43 | ${bindir}/nl-*" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 44 | FILES:${PN}-genl = "${libdir}/libnl-genl-3.so.* \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 45 | ${libdir}/libnl-genl.so.*" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 46 | FILES:${PN}-idiag = "${libdir}/libnl-idiag-3.so.*" |
| 47 | FILES:${PN}-nf = "${libdir}/libnl-nf-3.so.*" |
| 48 | FILES:${PN}-route = "${libdir}/libnl-route-3.so.*" |
| 49 | FILES:${PN}-xfrm = "${libdir}/libnl-xfrm-3.so.*" |
| 50 | RREPLACES:${PN}-genl = "libnl-genl2" |
| 51 | RCONFLICTS:${PN}-genl = "libnl-genl2" |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 52 | |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 53 | DEPENDS += "${@bb.utils.contains('PTEST_ENABLED', '1', 'libcheck', '', d)}" |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 54 | RRECOMMENDS:${PN}-ptest += "kernel-module-dummy kernel-module-bonding" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 55 | |
| 56 | do_compile_ptest() { |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 57 | oe_runmake ./tests/check-all |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 58 | } |
| 59 | |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 60 | do_install_ptest() { |
| 61 | ./libtool install install ./tests/check-all ${D}${PTEST_PATH}/ |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 62 | } |
| 63 | |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 64 | BBCLASSEXTEND = "native nativesdk" |