Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "PNG image format decoding library" |
| 2 | DESCRIPTION = "An open source project to develop and maintain the reference \ |
| 3 | library for use in applications that read, create, and manipulate PNG \ |
| 4 | (Portable Network Graphics) raster image files. " |
| 5 | HOMEPAGE = "http://www.libpng.org/" |
| 6 | SECTION = "libs" |
| 7 | LICENSE = "Libpng" |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8f533bc367bfd43f556b6f782234c076" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 9 | DEPENDS = "zlib" |
| 10 | |
| 11 | LIBV = "16" |
| 12 | |
| 13 | SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}${LIBV}/${BP}.tar.xz" |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 14 | SRC_URI[sha256sum] = "535b479b2467ff231a3ec6d92a525906fb8ef27978be4f66dbe05d3f3a01b3a1" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 15 | |
| 16 | MIRRORS += "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}${LIBV}/ ${SOURCEFORGE_MIRROR}/${BPN}/${BPN}${LIBV}/older-releases/" |
| 17 | |
| 18 | UPSTREAM_CHECK_URI = "http://libpng.org/pub/png/libpng.html" |
| 19 | |
| 20 | BINCONFIG = "${bindir}/libpng-config ${bindir}/libpng16-config" |
| 21 | |
| 22 | inherit autotools binconfig-disabled pkgconfig |
| 23 | |
| 24 | # Work around missing symbols |
| 25 | ARMNEON = "${@bb.utils.contains("TUNE_FEATURES", "neon", "--enable-arm-neon=on", "--enable-arm-neon=off", d)}" |
| 26 | ARMNEON:aarch64 = "--enable-hardware-optimizations=on" |
| 27 | EXTRA_OECONF += "${ARMNEON}" |
| 28 | |
| 29 | PACKAGES =+ "${PN}-tools" |
| 30 | |
| 31 | FILES:${PN}-tools = "${bindir}/png-fix-itxt ${bindir}/pngfix ${bindir}/pngcp" |
| 32 | |
| 33 | BBCLASSEXTEND = "native nativesdk" |
| 34 | |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 35 | CVE_STATUS[CVE-2019-17371] = "cpe-incorrect: A memory leak in gif2png 2.x" |