blob: 293bf2858d56ab590c83922e4a37dd375fb3f95f [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "PNG image format decoding library"
2DESCRIPTION = "An open source project to develop and maintain the reference \
3library for use in applications that read, create, and manipulate PNG \
4(Portable Network Graphics) raster image files. "
5HOMEPAGE = "http://www.libpng.org/"
6SECTION = "libs"
7LICENSE = "Libpng"
Andrew Geissler8f840682023-07-21 09:09:43 -05008LIC_FILES_CHKSUM = "file://LICENSE;md5=8f533bc367bfd43f556b6f782234c076"
Andrew Geissler517393d2023-01-13 08:55:19 -06009DEPENDS = "zlib"
10
11LIBV = "16"
12
13SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}${LIBV}/${BP}.tar.xz"
Andrew Geissler8f840682023-07-21 09:09:43 -050014SRC_URI[sha256sum] = "535b479b2467ff231a3ec6d92a525906fb8ef27978be4f66dbe05d3f3a01b3a1"
Andrew Geissler517393d2023-01-13 08:55:19 -060015
16MIRRORS += "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}${LIBV}/ ${SOURCEFORGE_MIRROR}/${BPN}/${BPN}${LIBV}/older-releases/"
17
18UPSTREAM_CHECK_URI = "http://libpng.org/pub/png/libpng.html"
19
20BINCONFIG = "${bindir}/libpng-config ${bindir}/libpng16-config"
21
22inherit autotools binconfig-disabled pkgconfig
23
24# Work around missing symbols
25ARMNEON = "${@bb.utils.contains("TUNE_FEATURES", "neon", "--enable-arm-neon=on", "--enable-arm-neon=off", d)}"
26ARMNEON:aarch64 = "--enable-hardware-optimizations=on"
27EXTRA_OECONF += "${ARMNEON}"
28
29PACKAGES =+ "${PN}-tools"
30
31FILES:${PN}-tools = "${bindir}/png-fix-itxt ${bindir}/pngfix ${bindir}/pngcp"
32
33BBCLASSEXTEND = "native nativesdk"
34
Andrew Geissler8f840682023-07-21 09:09:43 -050035CVE_STATUS[CVE-2019-17371] = "cpe-incorrect: A memory leak in gif2png 2.x"