Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "libusb-0.1 compatibility layer for libusb1" |
| 2 | DESCRIPTION = "libusb-0.1 compatible layer for libusb1, a drop-in replacement \ |
| 3 | that aims to look, feel and behave exactly like libusb-0.1" |
| 4 | HOMEPAGE = "http://www.libusb.org/" |
| 5 | BUGTRACKER = "http://www.libusb.org/report" |
| 6 | SECTION = "libs" |
| 7 | |
| 8 | LICENSE = "LGPLv2.1+" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f2ac5f3ac4835e8f91324a26a590a423" |
| 10 | DEPENDS = "libusb1" |
| 11 | |
| 12 | # Few packages are known not to work with libusb-compat (e.g. libmtp-1.0.0), |
| 13 | # so here libusb-0.1 is removed completely instead of adding virtual/libusb0. |
| 14 | # Besides, libusb-0.1 uses a per 1ms polling that hurts a lot to power |
| 15 | # consumption. |
| 16 | PROVIDES = "libusb virtual/libusb0" |
| 17 | BBCLASSEXTEND = "native nativesdk" |
| 18 | |
| 19 | PE = "1" |
| 20 | |
| 21 | SRC_URI = "${SOURCEFORGE_MIRROR}/libusb/libusb-compat-${PV}.tar.bz2 \ |
| 22 | file://0001-usb.h-Include-sys-types.h.patch \ |
| 23 | " |
| 24 | |
| 25 | SRC_URI[md5sum] = "2780b6a758a1e2c2943bdbf7faf740e4" |
| 26 | SRC_URI[sha256sum] = "404ef4b6b324be79ac1bfb3d839eac860fbc929e6acb1ef88793a6ea328bc55a" |
| 27 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 28 | UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/libusb/files/libusb-compat-0.1/" |
| 29 | UPSTREAM_CHECK_REGEX = "/libusb-compat-(?P<pver>(\d+[\.\-_]*)+)/$" |
| 30 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 31 | BINCONFIG = "${bindir}/libusb-config" |
| 32 | |
| 33 | inherit autotools pkgconfig binconfig-disabled lib_package |
| 34 | |
| 35 | EXTRA_OECONF = "--libdir=${base_libdir}" |
| 36 | |
| 37 | do_install_append() { |
| 38 | install -d ${D}${libdir} |
| 39 | if [ ! ${D}${libdir} -ef ${D}${base_libdir} ]; then |
| 40 | mv ${D}${base_libdir}/pkgconfig ${D}${libdir} |
| 41 | fi |
| 42 | } |