Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "GNOME configuration system" |
| 2 | SECTION = "x11/gnome" |
| 3 | LICENSE = "LGPLv2+" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605" |
| 5 | |
| 6 | DEPENDS = "glib-2.0 dbus dbus-glib libxml2 intltool-native gobject-introspection-stub" |
| 7 | DEPENDS_class-native = "glib-2.0-native dbus-native dbus-glib-native libxml2-native intltool-native gnome-common-native gobject-introspection-stub-native" |
| 8 | |
| 9 | |
| 10 | inherit gnomebase gtk-doc gettext |
| 11 | |
| 12 | SRC_URI = "${GNOME_MIRROR}/GConf/${@gnome_verdir("${PV}")}/GConf-${PV}.tar.xz;name=archive \ |
| 13 | file://remove_plus_from_invalid_characters_list.patch \ |
| 14 | file://unable-connect-dbus.patch \ |
| 15 | " |
| 16 | |
| 17 | SRC_URI[archive.md5sum] = "2b16996d0e4b112856ee5c59130e822c" |
| 18 | SRC_URI[archive.sha256sum] = "1912b91803ab09a5eed34d364bf09fe3a2a9c96751fde03a4e0cfa51a04d784c" |
| 19 | |
| 20 | S = "${WORKDIR}/GConf-${PV}" |
| 21 | |
| 22 | EXTRA_OECONF = "--enable-shared --disable-static --enable-debug=yes \ |
| 23 | --disable-introspection --disable-orbit --with-openldap=no --disable-gtk" |
| 24 | |
| 25 | # Disable PolicyKit by default |
| 26 | PACKAGECONFIG ??= "" |
| 27 | # We really don't want PolicyKit for native or uclibc |
| 28 | PACKAGECONFIG_class-native = "" |
| 29 | PACKAGECONFIG_libc-uclibc = "" |
| 30 | |
| 31 | PACKAGECONFIG[policykit] = "--enable-defaults-service,--disable-defaults-service,polkit" |
| 32 | |
| 33 | do_install_append() { |
| 34 | # this directory need to be created to avoid an Error 256 at gdm launch |
| 35 | install -d ${D}${sysconfdir}/gconf/gconf.xml.system |
| 36 | |
| 37 | # this stuff is unusable |
| 38 | rm -f ${D}${libdir}/GConf/*/*.*a |
| 39 | rm -f ${D}${libdir}/gio/*/*.*a |
| 40 | } |
| 41 | |
| 42 | do_install_append_class-native() { |
| 43 | create_wrapper ${D}/${bindir}/gconftool-2 \ |
| 44 | GCONF_BACKEND_DIR=${STAGING_LIBDIR_NATIVE}/GConf/2 |
| 45 | } |
| 46 | |
| 47 | # disable dbus-x11 when x11 isn't in DISTRO_FEATURES |
| 48 | RDEPENDS_${PN} += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'dbus-x11', '', d)}" |
| 49 | RDEPENDS_${PN}_class-native = "" |
| 50 | |
| 51 | FILES_${PN} += "${libdir}/GConf/* \ |
| 52 | ${libdir}/gio/*/*.so \ |
| 53 | ${datadir}/polkit* \ |
| 54 | ${datadir}/dbus-1/services/*.service \ |
| 55 | ${datadir}/dbus-1/system-services/*.service \ |
| 56 | " |
| 57 | FILES_${PN}-dbg += "${libdir}/*/*/.debug" |
| 58 | FILES_${PN}-dev += "${datadir}/sgml/gconf/gconf-1.0.dtd" |
| 59 | |
| 60 | BBCLASSEXTEND = "native" |