Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 1 | SUMMARY = "LVGL Demo Application for Framebuffer" |
| 2 | HOMEPAGE = "https://github.com/lvgl/lv_port_linux_frame_buffer" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=802d3d83ae80ef5f343050bf96cce3a4 \ |
| 5 | file://lvgl/LICENCE.txt;md5=bf1198c89ae87f043108cea62460b03a" |
| 6 | |
| 7 | SRC_URI = "\ |
| 8 | git://github.com/lvgl/lv_port_linux_frame_buffer.git;protocol=https;branch=master;name=demo \ |
| 9 | git://github.com/lvgl/lvgl;protocol=https;branch=master;name=lvgl;subdir=git/lvgl \ |
| 10 | file://0002-fix-sdl-handle-both-LV_IMAGE_SRC_FILE-and-LV_IMAGE_S.patch;patchdir=lvgl \ |
| 11 | file://0003-Make-fbdev-device-node-runtime-configurable-via-envi.patch \ |
| 12 | file://0004-Factor-out-fbdev-initialization-code.patch \ |
| 13 | file://0005-Add-DRM-KMS-example-support.patch \ |
| 14 | file://0006-Add-SDL2-example-support.patch \ |
| 15 | file://0007-fix-cmake-generate-versioned-shared-libraries.patch;patchdir=lvgl \ |
| 16 | file://0008-fix-fbdev-set-resolution-prior-to-buffer.patch;patchdir=lvgl \ |
| 17 | " |
| 18 | SRCREV_demo = "dccc6a1ca48372aa993dbea7a8e17dec6f42df6a" |
| 19 | SRCREV_lvgl = "e1c0b21b2723d391b885de4b2ee5cc997eccca91" |
| 20 | SRCREV_FORMAT = "demo_lvgl" |
| 21 | |
| 22 | EXTRA_OEMAKE = "DESTDIR=${D}" |
| 23 | |
| 24 | LVGL_CONFIG_DRM_CARD ?= "/dev/dri/card0" |
| 25 | LVGL_CONFIG_LV_USE_LOG = "1" |
| 26 | LVGL_CONFIG_LV_LOG_PRINTF = "1" |
| 27 | LVGL_CONFIG_LV_MEM_SIZE = "(256 * 1024U)" |
| 28 | LVGL_CONFIG_LV_USE_FONT_COMPRESSED = "1" |
| 29 | require lv-conf.inc |
| 30 | |
| 31 | inherit cmake |
| 32 | |
| 33 | S = "${WORKDIR}/git" |
| 34 | |
| 35 | do_configure:prepend() { |
| 36 | if [ "${LVGL_CONFIG_USE_SDL}" -eq 1 ] ; then |
| 37 | # Add libsdl build dependency, SDL2_image has no cmake file |
| 38 | sed -i '/^target_link_libraries/ s@pthread@& SDL2_image@' "${S}/CMakeLists.txt" |
| 39 | fi |
| 40 | } |
| 41 | |
| 42 | do_install:append() { |
| 43 | install -d ${D}${bindir} |
| 44 | install -m 0755 ${S}/bin/main ${D}${bindir}/lvgl |
| 45 | } |