blob: 09b91f6b37638cb4a3afb51467b3c4e01af4fdae [file] [log] [blame]
Andrew Geissler8f840682023-07-21 09:09:43 -05001SUMMARY = "Tools of dm-thin device-mapper"
2DESCRIPTION = "A suite of tools for manipulating the metadata of the dm-thin device-mapper target."
3HOMEPAGE = "https://github.com/jthornber/thin-provisioning-tools"
4LICENSE = "GPL-3.0-only"
5SECTION = "devel"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
8S = "${WORKDIR}/git"
9
10SRC_URI = " \
11 git://github.com/jthornber/thin-provisioning-tools;branch=main;protocol=https \
12 "
Andrew Geissler8f840682023-07-21 09:09:43 -050013
Patrick Williams03514f12024-04-05 07:04:11 -050014SRCREV = "b2d57dad4c3378544d7b36f3fc61e60989c5c092"
Andrew Geissler8f840682023-07-21 09:09:43 -050015UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
16
17inherit cargo cargo-update-recipe-crates
18
19require ${BPN}-crates.inc
20require ${BPN}-git-crates.inc
21
22do_install:append() {
Patrick Williams03514f12024-04-05 07:04:11 -050023 install -d ${D}${sbindir}
24 mv ${D}${bindir}/pdata_tools ${D}${sbindir}/pdata_tools
25 rmdir --ignore-fail-on-non-empty ${D}${bindir}
26
Andrew Geissler8f840682023-07-21 09:09:43 -050027 for tool in cache_check \
28 cache_dump \
29 cache_metadata_size \
30 cache_repair \
31 cache_restore \
32 cache_writeback \
33 thin_check \
34 thin_delta \
35 thin_dump \
36 thin_ls \
37 thin_repair \
38 thin_restore \
39 thin_rmap \
40 thin_metadata_size \
41 thin_metadata_pack \
42 thin_metadata_unpack \
43 thin_trim \
44 era_check \
45 era_dump \
46 era_invalidate \
47 era_restore; do
Patrick Williams03514f12024-04-05 07:04:11 -050048 ln -sf pdata_tools ${D}${sbindir}/$tool
Andrew Geissler8f840682023-07-21 09:09:43 -050049 done
50}