Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | PACKAGECONFIG_GL_rpi = "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'gl', \ |
Andrew Geissler | 1c34914 | 2019-02-19 19:49:56 -0600 | [diff] [blame^] | 2 | bb.utils.contains('DISTRO_FEATURES', 'opengl', 'eglfs gles2', \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 3 | '', d), d)}" |
Andrew Geissler | 1c34914 | 2019-02-19 19:49:56 -0600 | [diff] [blame^] | 4 | PACKAGECONFIG_GL_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', ' gbm kms', '', d)}" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 5 | PACKAGECONFIG_FONTS_rpi = "fontconfig" |
| 6 | PACKAGECONFIG_append_rpi = " libinput examples tslib xkb xkbcommon-evdev" |
| 7 | PACKAGECONFIG_remove_rpi = "tests" |
| 8 | |
Andrew Geissler | 1c34914 | 2019-02-19 19:49:56 -0600 | [diff] [blame^] | 9 | OE_QTBASE_EGLFS_DEVICE_INTEGRATION_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', 'eglfs_brcm', d)}" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 10 | |
| 11 | do_configure_prepend_rpi() { |
| 12 | # Add the appropriate EGLFS_DEVICE_INTEGRATION |
| 13 | if [ "${@d.getVar('OE_QTBASE_EGLFS_DEVICE_INTEGRATION')}" != "" ]; then |
Andrew Geissler | 1c34914 | 2019-02-19 19:49:56 -0600 | [diff] [blame^] | 14 | echo "EGLFS_DEVICE_INTEGRATION = ${OE_QTBASE_EGLFS_DEVICE_INTEGRATION}" >> ${S}/mkspecs/oe-device-extra.pri |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 15 | fi |
| 16 | } |
| 17 | RDEPENDS_${PN}_append_rpi = " userland" |