Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "ITS Tool allows you to translate your XML documents with PO files" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "It extracts messages from XML files and outputs PO template \ |
| 3 | files, then merges translations from MO files to create translated \ |
| 4 | XML files. It determines what to translate and how to chunk it into \ |
| 5 | messages using the W3C Internationalization Tag Set (ITS). " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 6 | HOMEPAGE = "http://itstool.org/" |
| 7 | LICENSE = "GPLv3" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=59c57b95fd7d0e9e238ebbc7ad47c5a5" |
| 9 | |
| 10 | inherit autotools python3native |
| 11 | |
| 12 | DEPENDS = "libxml2-native" |
| 13 | |
| 14 | SRC_URI = "http://files.itstool.org/${BPN}/${BPN}-${PV}.tar.bz2" |
| 15 | SRC_URI_append_class-native = " file://0001-Native-Don-t-use-build-time-hardcoded-python-binary-.patch" |
| 16 | SRC_URI_append_class-nativesdk = " file://0001-Native-Don-t-use-build-time-hardcoded-python-binary-.patch" |
| 17 | SRC_URI_append_class-target = " file://0002-Don-t-use-build-time-hardcoded-python-binary-path.patch" |
| 18 | |
| 19 | SRC_URI[md5sum] = "4306eeba4f4aee6b393d14f9c3c57ca1" |
| 20 | SRC_URI[sha256sum] = "6233cc22726a9a5a83664bf67d1af79549a298c23185d926c3677afa917b92a9" |
| 21 | |
| 22 | BBCLASSEXTEND = "native nativesdk" |
| 23 | |
| 24 | RDEPENDS_${PN} += "libxml2-python" |