blob: 21bd22043276e773d18a5747909c3afa63581a24 [file] [log] [blame]
Peter Yin7c0e43d2023-12-21 21:58:26 +08001LICENSE = "Apache-2.0"
2LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
3
4inherit allarch systemd obmc-phosphor-systemd
5
6RDEPENDS:${PN} += "bash"
7
8SRC_URI += " \
9 file://setup_gpio.sh \
10 file://power-util \
11 file://host-gpio.service \
12 file://host-poweroff.service \
13 file://host-poweron.service \
14 "
15
16SYSTEMD_PACKAGES = "${PN}"
17SYSTEMD_SERVICE:${PN}:append = " \
18 host-gpio.service host-poweron.service \
19 host-poweroff.service \
20 "
21
22S = "${WORKDIR}"
23
24do_install() {
25 install -d ${D}/usr/sbin
26 install -m 0755 ${S}/setup_gpio.sh ${D}/${sbindir}/
27 install -m 0755 ${S}/power-util ${D}/${sbindir}/
28}