Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "XML::Parser - A perl module for parsing XML documents" |
| 2 | HOMEPAGE = "https://libexpat.github.io/" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 5 | LIC_FILES_CHKSUM = "file://Parser.pm;beginline=1;endline=7;md5=d12cc778c80fc4c518f0e5dee29fd5fb" |
| 6 | |
| 7 | DEPENDS += "expat" |
| 8 | |
| 9 | SRC_URI = "http://www.cpan.org/modules/by-module/XML/XML-Parser-${PV}.tar.gz \ |
| 10 | file://ptest-perl/run-ptest \ |
| 11 | file://0001-CheckLib.pm-do-not-attempt-to-run-a-cross-executable.patch \ |
| 12 | " |
| 13 | SRC_URI[md5sum] = "80bb18a8e6240fcf7ec2f7b57601c170" |
| 14 | SRC_URI[sha256sum] = "d331332491c51cccfb4cb94ffc44f9cd73378e618498d4a37df9e043661c515d" |
| 15 | |
| 16 | S = "${WORKDIR}/XML-Parser-${PV}" |
| 17 | |
| 18 | EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR} CC='${CC}' LD='${CCLD}' FULL_AR='${AR}'" |
| 19 | |
| 20 | inherit cpan ptest-perl |
| 21 | |
| 22 | # fix up sub MakeMaker project as arguments don't get propagated though |
| 23 | # see https://rt.cpan.org/Public/Bug/Display.html?id=28632 |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 24 | do_configure:append:class-target() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 25 | sed -E \ |
| 26 | -e 's:-L${STAGING_LIBDIR}::g' -e 's:-I${STAGING_INCDIR}::g' \ |
| 27 | -i Makefile Expat/Makefile |
| 28 | } |
| 29 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 30 | do_configure:append() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 31 | sed -e 's:--sysroot=.*\(\s\|$\):--sysroot=${STAGING_DIR_TARGET} :g' \ |
| 32 | -i Makefile Expat/Makefile |
| 33 | sed 's:^FULL_AR = .*:FULL_AR = ${AR}:g' -i Expat/Makefile |
| 34 | # make sure these two do not build in parallel |
| 35 | sed 's!^$(INST_DYNAMIC):!$(INST_DYNAMIC): $(BOOTSTRAP)!' -i Expat/Makefile |
| 36 | } |
| 37 | |
| 38 | do_compile() { |
| 39 | export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')" |
| 40 | cpan_do_compile |
| 41 | } |
| 42 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 43 | do_compile:class-native() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 44 | cpan_do_compile |
| 45 | } |
| 46 | |
| 47 | do_install_ptest() { |
| 48 | sed -i -e "s:/usr/local/bin/perl:/usr/bin/perl:g" ${B}/samples/xmlstats |
| 49 | sed -i -e "s:/usr/local/bin/perl:/usr/bin/perl:g" ${B}/samples/xmlfilter |
| 50 | sed -i -e "s:/usr/local/bin/perl:/usr/bin/perl:g" ${B}/samples/xmlcomments |
| 51 | sed -i -e "s:/usr/local/bin/perl:/usr/bin/perl:g" ${B}/samples/canonical |
| 52 | cp -r ${B}/samples ${D}${PTEST_PATH} |
| 53 | chown -R root:root ${D}${PTEST_PATH}/samples |
| 54 | } |
| 55 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 56 | RDEPENDS:${PN}-ptest += "perl-module-filehandle perl-module-if perl-module-test perl-module-test-more" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 57 | |
| 58 | BBCLASSEXTEND="native nativesdk" |