blob: 32a43e00b991e341a0c77a554369a52274056cdc [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "With this program/Python library you can easily create mock objects on D-Bus"
2HOMEPAGE = "https://pypi.org/project/python-dbusmock/"
3
4LICENSE = "GPL-3.0-only"
5LIC_FILES_CHKSUM = "file://COPYING;md5=e6a600fd5e1d9cbde2d983680233ad02"
6
Patrick Williamsb542dec2023-06-09 01:26:37 -05007SRC_URI[sha256sum] = "3efdb3d800386b65e8854d8ee4538764241382b4e664423ad7d959c9008dd408"
Andrew Geissler517393d2023-01-13 08:55:19 -06008
9PYPI_PACKAGE = "python-dbusmock"
10
11inherit pypi python_setuptools_build_meta
12DEPENDS += "python3-setuptools-scm-native"
13
14RDEPENDS:${PN} += "\
15 ${PYTHON_PN}-dbus \
16 ${PYTHON_PN}-pygobject \
17 ${PYTHON_PN}-unittest \
18 ${PYTHON_PN}-xml \
19 "
20
21BBCLASSEXTEND = "native"