Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | require gstreamer1.0-plugins-common.inc |
| 2 | |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 3 | DESCRIPTION = "'Bad' GStreamer plugins and helper libraries " |
| 4 | HOMEPAGE = "https://gstreamer.freedesktop.org/" |
| 5 | BUGTRACKER = "https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/issues" |
| 6 | |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 7 | SRC_URI = "https://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-${PV}.tar.xz \ |
| 8 | file://0001-fix-maybe-uninitialized-warnings-when-compiling-with.patch \ |
| 9 | file://0002-avoid-including-sys-poll.h-directly.patch \ |
| 10 | file://0003-ensure-valid-sentinals-for-gst_structure_get-etc.patch \ |
| 11 | file://0004-opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch \ |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 12 | file://0005-msdk-fix-includedir-path.patch \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 13 | " |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 14 | SRC_URI[sha256sum] = "74e806bc5595b18c70e9ca93571e27e79dfb808e5d2e7967afa952b52e99c85f" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 15 | |
| 16 | S = "${WORKDIR}/gst-plugins-bad-${PV}" |
| 17 | |
| 18 | LICENSE = "GPLv2+ & LGPLv2+ & LGPLv2.1+" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 19 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 20 | |
| 21 | DEPENDS += "gstreamer1.0-plugins-base" |
| 22 | |
| 23 | inherit gobject-introspection |
| 24 | |
| 25 | PACKAGECONFIG ??= " \ |
| 26 | ${GSTREAMER_ORC} \ |
| 27 | ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \ |
| 28 | ${@bb.utils.filter('DISTRO_FEATURES', 'directfb vulkan', d)} \ |
| 29 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)} \ |
| 30 | ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gl', '', d)} \ |
Andrew Geissler | c926e17 | 2021-05-07 16:11:35 -0500 | [diff] [blame] | 31 | bz2 closedcaption curl dash dtls hls openssl rsvg sbc smoothstreaming \ |
| 32 | sndfile ttml uvch264 webp \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 33 | " |
| 34 | |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 35 | PACKAGECONFIG[aom] = "-Daom=enabled,-Daom=disabled,aom" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 36 | PACKAGECONFIG[assrender] = "-Dassrender=enabled,-Dassrender=disabled,libass" |
| 37 | PACKAGECONFIG[bluez] = "-Dbluez=enabled,-Dbluez=disabled,bluez5" |
| 38 | PACKAGECONFIG[bz2] = "-Dbz2=enabled,-Dbz2=disabled,bzip2" |
| 39 | PACKAGECONFIG[closedcaption] = "-Dclosedcaption=enabled,-Dclosedcaption=disabled,pango cairo" |
| 40 | PACKAGECONFIG[curl] = "-Dcurl=enabled,-Dcurl=disabled,curl" |
| 41 | PACKAGECONFIG[dash] = "-Ddash=enabled,-Ddash=disabled,libxml2" |
| 42 | PACKAGECONFIG[dc1394] = "-Ddc1394=enabled,-Ddc1394=disabled,libdc1394" |
| 43 | PACKAGECONFIG[directfb] = "-Ddirectfb=enabled,-Ddirectfb=disabled,directfb" |
| 44 | PACKAGECONFIG[dtls] = "-Ddtls=enabled,-Ddtls=disabled,openssl" |
| 45 | PACKAGECONFIG[faac] = "-Dfaac=enabled,-Dfaac=disabled,faac" |
| 46 | PACKAGECONFIG[faad] = "-Dfaad=enabled,-Dfaad=disabled,faad2" |
| 47 | PACKAGECONFIG[fluidsynth] = "-Dfluidsynth=enabled,-Dfluidsynth=disabled,fluidsynth" |
Andrew Geissler | c926e17 | 2021-05-07 16:11:35 -0500 | [diff] [blame] | 48 | PACKAGECONFIG[hls] = "-Dhls=enabled,-Dhls=disabled," |
| 49 | # Pick atleast one crypto backend below when enabling hls |
| 50 | PACKAGECONFIG[nettle] = "-Dhls-crypto=nettle,,nettle" |
| 51 | PACKAGECONFIG[openssl] = "-Dhls-crypto=openssl,,openssl" |
| 52 | PACKAGECONFIG[gcrypt] = "-Dhls-crypto=libgcrypt,,libgcrypt" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 53 | # the gl packageconfig enables OpenGL elements that haven't been ported |
| 54 | # to -base yet. They depend on the gstgl library in -base, so we do |
| 55 | # not add GL dependencies here, since these are taken care of in -base. |
| 56 | PACKAGECONFIG[gl] = "-Dgl=enabled,-Dgl=disabled," |
| 57 | PACKAGECONFIG[kms] = "-Dkms=enabled,-Dkms=disabled,libdrm" |
| 58 | PACKAGECONFIG[libde265] = "-Dlibde265=enabled,-Dlibde265=disabled,libde265" |
| 59 | PACKAGECONFIG[libmms] = "-Dlibmms=enabled,-Dlibmms=disabled,libmms" |
| 60 | PACKAGECONFIG[libssh2] = "-Dcurl-ssh2=enabled,-Dcurl-ssh2=disabled,libssh2" |
| 61 | PACKAGECONFIG[lcms2] = "-Dcolormanagement=enabled,-Dcolormanagement=disabled,lcms" |
| 62 | PACKAGECONFIG[modplug] = "-Dmodplug=enabled,-Dmodplug=disabled,libmodplug" |
| 63 | PACKAGECONFIG[msdk] = "-Dmsdk=enabled,-Dmsdk=disabled,intel-mediasdk" |
| 64 | PACKAGECONFIG[neon] = "-Dneon=enabled,-Dneon=disabled,neon" |
| 65 | PACKAGECONFIG[openal] = "-Dopenal=enabled,-Dopenal=disabled,openal-soft" |
| 66 | PACKAGECONFIG[opencv] = "-Dopencv=enabled,-Dopencv=disabled,opencv" |
| 67 | PACKAGECONFIG[openh264] = "-Dopenh264=enabled,-Dopenh264=disabled,openh264" |
| 68 | PACKAGECONFIG[openjpeg] = "-Dopenjpeg=enabled,-Dopenjpeg=disabled,openjpeg" |
| 69 | PACKAGECONFIG[openmpt] = "-Dopenmpt=enabled,-Dopenmpt=disabled,libopenmpt" |
| 70 | # the opus encoder/decoder elements are now in the -base package, |
| 71 | # but the opus parser remains in -bad |
| 72 | PACKAGECONFIG[opusparse] = "-Dopus=enabled,-Dopus=disabled,libopus" |
| 73 | PACKAGECONFIG[resindvd] = "-Dresindvd=enabled,-Dresindvd=disabled,libdvdread libdvdnav" |
| 74 | PACKAGECONFIG[rsvg] = "-Drsvg=enabled,-Drsvg=disabled,librsvg" |
| 75 | PACKAGECONFIG[rtmp] = "-Drtmp=enabled,-Drtmp=disabled,rtmpdump" |
| 76 | PACKAGECONFIG[sbc] = "-Dsbc=enabled,-Dsbc=disabled,sbc" |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 77 | PACKAGECONFIG[sctp] = "-Dsctp=enabled,-Dsctp=disabled" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 78 | PACKAGECONFIG[smoothstreaming] = "-Dsmoothstreaming=enabled,-Dsmoothstreaming=disabled,libxml2" |
| 79 | PACKAGECONFIG[sndfile] = "-Dsndfile=enabled,-Dsndfile=disabled,libsndfile1" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 80 | PACKAGECONFIG[srt] = "-Dsrt=enabled,-Dsrt=disabled,srt" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 81 | PACKAGECONFIG[srtp] = "-Dsrtp=enabled,-Dsrtp=disabled,libsrtp" |
| 82 | PACKAGECONFIG[tinyalsa] = "-Dtinyalsa=enabled,-Dtinyalsa=disabled,tinyalsa" |
| 83 | PACKAGECONFIG[ttml] = "-Dttml=enabled,-Dttml=disabled,libxml2 pango cairo" |
| 84 | PACKAGECONFIG[uvch264] = "-Duvch264=enabled,-Duvch264=disabled,libusb1 libgudev" |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 85 | PACKAGECONFIG[v4l2codecs] = "-Dv4l2codecs=enabled,-Dv4l2codecs=disabled,libgudev" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 86 | PACKAGECONFIG[va] = "-Dva=enabled,-Dva=disabled,libva" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 87 | PACKAGECONFIG[voaacenc] = "-Dvoaacenc=enabled,-Dvoaacenc=disabled,vo-aacenc" |
| 88 | PACKAGECONFIG[voamrwbenc] = "-Dvoamrwbenc=enabled,-Dvoamrwbenc=disabled,vo-amrwbenc" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 89 | PACKAGECONFIG[vulkan] = "-Dvulkan=enabled,-Dvulkan=disabled,vulkan-loader shaderc-native" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 90 | PACKAGECONFIG[wayland] = "-Dwayland=enabled,-Dwayland=disabled,wayland-native wayland wayland-protocols libdrm" |
| 91 | PACKAGECONFIG[webp] = "-Dwebp=enabled,-Dwebp=disabled,libwebp" |
| 92 | PACKAGECONFIG[webrtc] = "-Dwebrtc=enabled,-Dwebrtc=disabled,libnice" |
| 93 | PACKAGECONFIG[webrtcdsp] = "-Dwebrtcdsp=enabled,-Dwebrtcdsp=disabled,webrtc-audio-processing" |
| 94 | PACKAGECONFIG[zbar] = "-Dzbar=enabled,-Dzbar=disabled,zbar" |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 95 | PACKAGECONFIG[x265] = "-Dx265=enabled,-Dx265=disabled,x265" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 96 | |
| 97 | EXTRA_OEMESON += " \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 98 | -Ddoc=disabled \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 99 | -Ddecklink=enabled \ |
| 100 | -Ddvb=enabled \ |
| 101 | -Dfbdev=enabled \ |
| 102 | -Dipcpipeline=enabled \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 103 | -Dshm=enabled \ |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 104 | -Dtranscode=enabled \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 105 | -Dandroidmedia=disabled \ |
| 106 | -Dapplemedia=disabled \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 107 | -Davtp=disabled \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 108 | -Dbs2b=disabled \ |
| 109 | -Dchromaprint=disabled \ |
| 110 | -Dd3dvideosink=disabled \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 111 | -Dd3d11=disabled \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 112 | -Ddirectsound=disabled \ |
| 113 | -Ddts=disabled \ |
| 114 | -Dfdkaac=disabled \ |
| 115 | -Dflite=disabled \ |
| 116 | -Dgme=disabled \ |
| 117 | -Dgsm=disabled \ |
| 118 | -Diqa=disabled \ |
| 119 | -Dkate=disabled \ |
| 120 | -Dladspa=disabled \ |
| 121 | -Dlv2=disabled \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 122 | -Dmagicleap=disabled \ |
| 123 | -Dmediafoundation=disabled \ |
| 124 | -Dmicrodns=disabled \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 125 | -Dmpeg2enc=disabled \ |
| 126 | -Dmplex=disabled \ |
| 127 | -Dmusepack=disabled \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 128 | -Dnvcodec=disabled \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 129 | -Dofa=disabled \ |
| 130 | -Dopenexr=disabled \ |
| 131 | -Dopenni2=disabled \ |
| 132 | -Dopensles=disabled \ |
| 133 | -Dsoundtouch=disabled \ |
| 134 | -Dspandsp=disabled \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 135 | -Dsvthevcenc=disabled \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 136 | -Dteletext=disabled \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 137 | -Dwasapi=disabled \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 138 | -Dwasapi2=disabled \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 139 | -Dwildmidi=disabled \ |
| 140 | -Dwinks=disabled \ |
| 141 | -Dwinscreencap=disabled \ |
| 142 | -Dwpe=disabled \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 143 | -Dzxing=disabled \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 144 | " |
| 145 | |
| 146 | export OPENCV_PREFIX = "${STAGING_DIR_TARGET}${prefix}" |
| 147 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 148 | ARM_INSTRUCTION_SET:armv4 = "arm" |
| 149 | ARM_INSTRUCTION_SET:armv5 = "arm" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 150 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 151 | FILES:${PN}-freeverb += "${datadir}/gstreamer-1.0/presets/GstFreeverb.prs" |
| 152 | FILES:${PN}-opencv += "${datadir}/gst-plugins-bad/1.0/opencv*" |
| 153 | FILES:${PN}-transcode += "${datadir}/gstreamer-1.0/encoding-profiles" |
| 154 | FILES:${PN}-voamrwbenc += "${datadir}/gstreamer-1.0/presets/GstVoAmrwbEnc.prs" |