Andrew Geissler | cc58928 | 2020-09-18 13:34:40 -0500 | [diff] [blame] | 1 | SUMMARY = "IBM's Software TPM 2.0 TSS" |
| 2 | DESCRIPTION = "This is a user space TSS for TPM 2.0. It implements the \ |
| 3 | functionality equivalent to (but not API compatible with) the TCG TSS \ |
| 4 | working group's ESAPI, SAPI, and TCTI API's (and perhaps more) but with a \ |
| 5 | hopefully simpler interface. \ |
| 6 | It comes with over 110 'TPM tools' samples that can be used for scripted \ |
| 7 | apps, rapid prototyping, education, and debugging. \ |
| 8 | It also comes with a web based TPM interface, suitable for a demo to an \ |
| 9 | audience that is unfamiliar with TCG technology. It is also useful for \ |
| 10 | basic TPM management." |
| 11 | HOMEPAGE = "http://ibmswtpm.sourceforge.net/ibmtss2.html" |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 12 | LICENSE = "BSD-2-Clause" |
Andrew Geissler | cc58928 | 2020-09-18 13:34:40 -0500 | [diff] [blame] | 13 | SECTION = "securty/tpm" |
| 14 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1e023f61454ac828b4aa1bc4293f7d5f" |
| 15 | |
| 16 | DEPENDS = "openssl ibmswtpm2" |
| 17 | |
| 18 | inherit autotools pkgconfig |
| 19 | |
William A. Kennington III | ee32beb | 2021-06-02 12:48:35 -0700 | [diff] [blame] | 20 | SRCREV = "c4e131e34ec0ed09411aa3bc76f76129ef881573" |
Patrick Williams | db4c27e | 2022-08-05 08:10:29 -0500 | [diff] [blame] | 21 | SRC_URI = "git://git.code.sf.net/p/ibmtpm20tss/tss;protocol=https;branch=master \ |
Andrew Geissler | cc58928 | 2020-09-18 13:34:40 -0500 | [diff] [blame] | 22 | file://0001-utils-12-Makefile.am-expand-wildcards-in-prereqs.patch \ |
| 23 | " |
| 24 | |
William A. Kennington III | ee32beb | 2021-06-02 12:48:35 -0700 | [diff] [blame] | 25 | UPSTREAM_CHECK_COMMITS = "1" |
Patrick Williams | db4c27e | 2022-08-05 08:10:29 -0500 | [diff] [blame] | 26 | UPSTREAM_CHECK_URI = "https://git.code.sf.net/p/ibmswtpm2/tpm2" |
| 27 | UPSTREAM_CHECK_GITTAGREGEX = "rev.*)" |
William A. Kennington III | ee32beb | 2021-06-02 12:48:35 -0700 | [diff] [blame] | 28 | |
Andrew Geissler | cc58928 | 2020-09-18 13:34:40 -0500 | [diff] [blame] | 29 | EXTRA_OECONF = "--disable-tpm-1.2" |
| 30 | |
| 31 | S = "${WORKDIR}/git" |