Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "ACPICA tools for the development and debug of ACPI tables" |
| 2 | DESCRIPTION = "The ACPI Component Architecture (ACPICA) project provides an \ |
| 3 | OS-independent reference implementation of the Advanced Configuration and \ |
| 4 | Power Interface Specification (ACPI). ACPICA code contains those portions of \ |
| 5 | ACPI meant to be directly integrated into the host OS as a kernel-resident \ |
| 6 | subsystem, and a small set of tools to assist in developing and debugging \ |
| 7 | ACPI tables." |
| 8 | |
| 9 | HOMEPAGE = "http://www.acpica.org/" |
| 10 | SECTION = "console/tools" |
| 11 | |
| 12 | LICENSE = "BSD | GPLv2" |
| 13 | LIC_FILES_CHKSUM = "file://generate/unix/readme.txt;md5=204407e197c1a01154a48f6c6280c3aa" |
| 14 | |
| 15 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" |
| 16 | |
| 17 | DEPENDS = "bison flex" |
| 18 | |
| 19 | SRC_URI = "https://acpica.org/sites/acpica/files/acpica-unix2-${PV}.tar.gz \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 20 | file://rename-yy_scan_string-manually.patch \ |
| 21 | file://manipulate-fds-instead-of-FILE.patch;striplevel=2 \ |
| 22 | file://0001-Linux-add-support-for-X32-ABI-compilation.patch \ |
| 23 | " |
| 24 | SRC_URI[md5sum] = "48ef4314fb4ffdd0c96f14dcf20544e1" |
| 25 | SRC_URI[sha256sum] = "b2d81e84107ac9a02be86ea43cbea7afa8fd4b4150270bc88c2d4c9fea0b8aad" |
| 26 | UPSTREAM_CHECK_URI = "https://acpica.org/downloads" |
| 27 | |
| 28 | S = "${WORKDIR}/acpica-unix2-${PV}" |
| 29 | |
| 30 | inherit update-alternatives |
| 31 | |
| 32 | ALTERNATIVE_PRIORITY = "100" |
| 33 | ALTERNATIVE_${PN} = "acpixtract" |
| 34 | |
| 35 | EXTRA_OEMAKE = "CC='${CC}' 'OPT_CFLAGS=-Wall'" |
| 36 | |
| 37 | do_install() { |
| 38 | install -D -p -m0755 generate/unix/bin*/iasl ${D}${bindir}/iasl |
| 39 | install -D -p -m0755 generate/unix/bin*/acpibin ${D}${bindir}/acpibin |
| 40 | install -D -p -m0755 generate/unix/bin*/acpiexec ${D}${bindir}/acpiexec |
| 41 | install -D -p -m0755 generate/unix/bin*/acpihelp ${D}${bindir}/acpihelp |
| 42 | install -D -p -m0755 generate/unix/bin*/acpinames ${D}${bindir}/acpinames |
| 43 | install -D -p -m0755 generate/unix/bin*/acpisrc ${D}${bindir}/acpisrc |
| 44 | install -D -p -m0755 generate/unix/bin*/acpixtract ${D}${bindir}/acpixtract |
| 45 | } |
| 46 | |
| 47 | # iasl*.bb is a subset of this recipe, so RREPLACE it |
| 48 | PROVIDES = "iasl" |
| 49 | RPROVIDES_${PN} += "iasl" |
| 50 | RREPLACES_${PN} += "iasl" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 51 | RCONFLICTS_${PN} += "iasl" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 52 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 53 | BBCLASSEXTEND = "native" |