Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | KBRANCH ?= "v4.14/standard/tiny/common-pc" |
| 2 | LINUX_KERNEL_TYPE = "tiny" |
| 3 | KCONFIG_MODE = "--allnoconfig" |
| 4 | |
| 5 | require recipes-kernel/linux/linux-yocto.inc |
| 6 | |
Brad Bishop | d5ae7d9 | 2018-06-14 09:52:03 -0700 | [diff] [blame] | 7 | LINUX_VERSION ?= "4.14.48" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 8 | |
| 9 | DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}" |
| 10 | DEPENDS += "openssl-native util-linux-native" |
| 11 | |
| 12 | KMETA = "kernel-meta" |
| 13 | KCONF_BSP_AUDIT_LEVEL = "2" |
| 14 | |
Brad Bishop | d5ae7d9 | 2018-06-14 09:52:03 -0700 | [diff] [blame] | 15 | SRCREV_machine ?= "9e246607d5c23f8bb3b8800734b1707766e0b2b9" |
| 16 | SRCREV_meta ?= "94457657b8d621868672917d1c2631df4a4fadd8" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 17 | |
| 18 | PV = "${LINUX_VERSION}+git${SRCPV}" |
| 19 | |
| 20 | SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \ |
| 21 | git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.14;destsuffix=${KMETA}" |
| 22 | |
| 23 | COMPATIBLE_MACHINE = "qemux86|qemux86-64" |
| 24 | |
| 25 | # Functionality flags |
| 26 | KERNEL_FEATURES = "" |
| 27 | |
| 28 | KERNEL_DEVICETREE_qemuarm = "versatile-pb.dtb" |