blob: 58945f25d081a960b24b96d30d08e43d26e68eb0 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001KBRANCH ?= "v4.14/standard/tiny/common-pc"
2LINUX_KERNEL_TYPE = "tiny"
3KCONFIG_MODE = "--allnoconfig"
4
5require recipes-kernel/linux/linux-yocto.inc
6
Brad Bishopd5ae7d92018-06-14 09:52:03 -07007LINUX_VERSION ?= "4.14.48"
Brad Bishop316dfdd2018-06-25 12:45:53 -04008
9DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
10DEPENDS += "openssl-native util-linux-native"
11
12KMETA = "kernel-meta"
13KCONF_BSP_AUDIT_LEVEL = "2"
14
Brad Bishopd5ae7d92018-06-14 09:52:03 -070015SRCREV_machine ?= "9e246607d5c23f8bb3b8800734b1707766e0b2b9"
16SRCREV_meta ?= "94457657b8d621868672917d1c2631df4a4fadd8"
Brad Bishop316dfdd2018-06-25 12:45:53 -040017
18PV = "${LINUX_VERSION}+git${SRCPV}"
19
20SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
21 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.14;destsuffix=${KMETA}"
22
23COMPATIBLE_MACHINE = "qemux86|qemux86-64"
24
25# Functionality flags
26KERNEL_FEATURES = ""
27
28KERNEL_DEVICETREE_qemuarm = "versatile-pb.dtb"