Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | # Copyright (C) 2016 Khem Raj <raj.khem@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | SUMMARY = "Open-source software for volunteer computing" |
| 5 | DESCRIPTION = "The Berkeley Open Infrastructure for Network Computing (BOINC) is an open- \ |
| 6 | source software platform which supports distributed computing, primarily in \ |
| 7 | the form of volunteer computing and desktop Grid computing. It is well \ |
| 8 | suited for problems which are often described as trivially parallel. BOINC \ |
| 9 | is the underlying software used by projects such as SETI@home, Einstein@Home, \ |
| 10 | ClimatePrediciton.net, the World Community Grid, and many other distributed \ |
| 11 | computing projects. \ |
| 12 | This package installs the BOINC client software, which will allow your \ |
| 13 | computer to participate in one or more BOINC projects, using your spare \ |
| 14 | computer time to search for cures for diseases, model protein folding, study \ |
| 15 | global warming, discover sources of gravitational waves, and many other types \ |
| 16 | of scientific and mathematical research." |
| 17 | |
| 18 | HOMEPAGE = "http://boinc.berkeley.edu/" |
| 19 | LICENSE = "LGPLv2+ & GPLv3" |
| 20 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \ |
| 21 | file://COPYING.LESSER;md5=6a6a8e020838b23406c81b19c1d46df6" |
| 22 | SECTION = "applications" |
| 23 | DEPENDS = "curl \ |
| 24 | jpeg \ |
| 25 | openssl \ |
| 26 | sqlite3 \ |
| 27 | virtual/libgl \ |
| 28 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'libnotify', '', d)} \ |
| 29 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gtk+ libnotify xcb-util libxscrnsaver', '', d)} \ |
| 30 | nettle \ |
| 31 | " |
| 32 | SRCREV = "bd12338dbd29083daa5a4b022592ca31ff68cd98" |
| 33 | BRANCH = "client_release/7/${PV}" |
| 34 | SRC_URI = "git://github.com/BOINC/boinc;protocol=https;branch=${BRANCH} \ |
| 35 | file://boinc-AM_CONDITIONAL.patch \ |
| 36 | file://opengl_m4_check.patch \ |
| 37 | file://gtk-configure.patch \ |
| 38 | " |
| 39 | |
| 40 | inherit gettext autotools pkgconfig distro_features_check systemd |
| 41 | |
| 42 | REQUIRED_DISTRO_FEATURES += "opengl" |
| 43 | |
| 44 | S = "${WORKDIR}/git" |
| 45 | |
| 46 | EXTRA_OECONF += "\ |
| 47 | --enable-libraries \ |
| 48 | --enable-unicode \ |
| 49 | --enable-shared \ |
| 50 | --enable-dynamic-client-linkage \ |
| 51 | --enable-client \ |
| 52 | --disable-server \ |
| 53 | --disable-static \ |
| 54 | --disable-manager \ |
| 55 | --with-ssl=${STAGING_EXECPREFIXDIR} \ |
| 56 | --without-wxdir \ |
| 57 | --without-x \ |
| 58 | --with-boinc-platform=${TARGET_SYS} \ |
| 59 | " |
| 60 | export PKG_CONFIG = "${STAGING_BINDIR_NATIVE}/pkg-config" |
| 61 | |
| 62 | do_configure_prepend () { |
| 63 | if "${@bb.utils.contains('DEPENDS', 'gtk+', '1', '0', d)}" = "0" |
| 64 | then |
| 65 | export GTK2_CFLAGS="" |
| 66 | export GTK2_LIBS="" |
| 67 | fi |
| 68 | } |
| 69 | |
| 70 | do_compile_prepend () { |
| 71 | # Disable rpaths |
| 72 | sed -i -e 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' ${B}/${TARGET_SYS}-libtool |
| 73 | sed -i -e 's|^sys_lib_dlsearch_path_spec=.*|sys_lib_dlsearch_path_spec=""|g' ${B}/${TARGET_SYS}-libtool |
| 74 | sed -i -e 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' ${B}/${TARGET_SYS}-libtool |
| 75 | } |
| 76 | do_install_append() { |
| 77 | if [ -e ${D}${libdir}/systemd/system/boinc-client.service ]; then |
| 78 | install -D -m 0644 \ |
| 79 | ${D}${libdir}/systemd/system/boinc-client.service \ |
| 80 | ${D}${systemd_system_unitdir}/boinc-client.service |
| 81 | rm -rf ${D}${libdir}/systemd |
| 82 | fi |
| 83 | } |
| 84 | |
| 85 | SYSTEMD_SERVICE_${PN} = "boinc-client.service" |
| 86 | |
| 87 | FILES_${PN} += "${libdir}/systemd" |