Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | DESCRIPTION = "libxml-perl is a collection of smaller Perl modules, scripts, and \ |
| 2 | documents for working with XML in Perl. libxml-perl software \ |
| 3 | works in combination with XML::Parser, PerlSAX, XML::DOM, \ |
| 4 | XML::Grove and others." |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 5 | HOMEPAGE = "http://search.cpan.org/dist/libxml-perl/" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 6 | SUMMARY = "Collection of Perl modules for working with XML" |
| 7 | SECTION = "libs" |
| 8 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 9 | PR = "r3" |
| 10 | |
| 11 | LIC_FILES_CHKSUM = "file://README;beginline=33;endline=35;md5=1705549eef7577a3d6ba71123a1f0ce8" |
| 12 | |
| 13 | DEPENDS += "libxml-parser-perl" |
| 14 | |
| 15 | SRC_URI = "http://www.cpan.org/modules/by-module/XML/${BPN}-${PV}.tar.gz" |
| 16 | |
| 17 | SRC_URI[md5sum] = "0ed5fbdda53d1301ddaed88db10503bb" |
| 18 | SRC_URI[sha256sum] = "4571059b7b5d48b7ce52b01389e95d798bf5cf2020523c153ff27b498153c9cb" |
| 19 | |
| 20 | EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}" |
| 21 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 22 | inherit cpan ptest-perl |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 23 | |
| 24 | do_compile() { |
| 25 | export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')" |
| 26 | cpan_do_compile |
| 27 | } |
| 28 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 29 | RDEPENDS_${PN} += "perl-module-carp perl-module-overload perl-module-universal perl-module-io-handle" |
| 30 | RDEPENDS_${PN}-ptest += "libxml-parser-perl perl-module-file-glob" |