Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Perl module for reading and writing XML" |
| 2 | DESCRIPTION = "The XML::Simple Perl module provides a simple API layer \ |
| 3 | on top of an underlying XML parsing module to maintain XML files \ |
| 4 | (especially configuration files). It is a blunt rewrite of XML::Simple \ |
| 5 | (by Grant McLean) to use the XML::LibXML parser for XML structures, \ |
| 6 | where the original uses plain Perl or SAX parsers." |
| 7 | HOMEPAGE = "http://search.cpan.org/~markov/XML-LibXML-Simple-0.93/lib/XML/LibXML/Simple.pod" |
| 8 | SECTION = "libs" |
| 9 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=cf206df8c9fe775f1d4c484386491eac" |
| 11 | DEPENDS += "libxml-parser-perl" |
| 12 | |
| 13 | SRC_URI = "http://www.cpan.org/modules/by-module/XML/XML-Simple-${PV}.tar.gz" |
| 14 | |
| 15 | SRC_URI[md5sum] = "bb841dce889a26c89a1c2739970e9fbc" |
| 16 | SRC_URI[sha256sum] = "531fddaebea2416743eb5c4fdfab028f502123d9a220405a4100e68fc480dbf8" |
| 17 | |
| 18 | S = "${WORKDIR}/XML-Simple-${PV}" |
| 19 | |
| 20 | EXTRA_PERLFLAGS = "-I ${PERLHOSTLIB}" |
| 21 | |
| 22 | inherit cpan ptest-perl |
| 23 | |
| 24 | RDEPENDS_${PN} += " \ |
| 25 | libxml-namespacesupport-perl \ |
| 26 | libxml-parser-perl \ |
| 27 | libxml-sax-perl \ |
| 28 | " |
| 29 | |
| 30 | RDEPENDS_${PN}-ptest += " \ |
| 31 | perl-module-file-temp \ |
| 32 | perl-module-test-more \ |
| 33 | " |
| 34 | |
| 35 | BBCLASSEXTEND = "native" |