Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "SWTPM - Software TPM Emulator" |
| 2 | LICENSE = "BSD-3-Clause" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=fe8092c832b71ef20dfe4c6d3decb3a8" |
| 4 | SECTION = "apps" |
| 5 | |
| 6 | DEPENDS = "libtasn1 expect socat glib-2.0 net-tools-native libtpm libtpm-native" |
| 7 | |
| 8 | # configure checks for the tools already during compilation and |
| 9 | # then swtpm_setup needs them at runtime |
| 10 | DEPENDS += "tpm-tools-native expect-native socat-native" |
| 11 | |
Brad Bishop | a3b01f4 | 2019-09-13 06:30:46 -0400 | [diff] [blame] | 12 | SRCREV = "39673a0139b0ee14a0109aba50a0635592c672c4" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 13 | SRC_URI = "git://github.com/stefanberger/swtpm.git;branch=stable-${PV} \ |
| 14 | file://fix_fcntl_h.patch \ |
| 15 | file://ioctl_h.patch \ |
| 16 | " |
| 17 | PE = "1" |
| 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | inherit autotools pkgconfig |
| 22 | PARALLEL_MAKE = "" |
| 23 | |
| 24 | TSS_USER="tss" |
| 25 | TSS_GROUP="tss" |
| 26 | |
| 27 | PACKAGECONFIG ?= "openssl" |
| 28 | PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}" |
| 29 | PACKAGECONFIG += "${@bb.utils.contains('BBFILE_COLLECTIONS', 'filesystems-layer', 'cuse', '', d)}" |
| 30 | PACKAGECONFIG[openssl] = "--with-openssl, --without-openssl, openssl" |
| 31 | PACKAGECONFIG[gnutls] = "--with-gnutls, --without-gnutls, gnutls" |
| 32 | PACKAGECONFIG[selinux] = "--with-selinux, --without-selinux, libselinux" |
| 33 | PACKAGECONFIG[cuse] = "--with-cuse, --without-cuse, fuse" |
Andrew Geissler | 1fe918a | 2020-05-15 14:16:47 -0500 | [diff] [blame^] | 34 | PACKAGECONFIG[seccomp] = "--with-seccomp, --without-seccomp, libseccomp" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 35 | |
| 36 | EXTRA_OECONF += "--with-tss-user=${TSS_USER} --with-tss-group=${TSS_GROUP}" |
| 37 | |
| 38 | export SEARCH_DIR = "${STAGING_LIBDIR_NATIVE}" |
| 39 | |
| 40 | USERADD_PACKAGES = "${PN}" |
| 41 | GROUPADD_PARAM_${PN} = "--system ${TSS_USER}" |
| 42 | USERADD_PARAM_${PN} = "--system -g ${TSS_GROUP} --home-dir \ |
| 43 | --no-create-home --shell /bin/false ${BPN}" |
| 44 | |
| 45 | PACKAGE_BEFORE_PN = "${PN}-cuse" |
| 46 | FILES_${PN}-cuse = "${bindir}/swtpm_cuse" |
| 47 | |
| 48 | INSANE_SKIP_${PN} += "dev-so" |
| 49 | |
| 50 | RDEPENDS_${PN} = "libtpm expect socat bash tpm-tools" |
| 51 | |
| 52 | BBCLASSEXTEND = "native nativesdk" |