Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "H.265/HEVC video encoder" |
| 2 | DESCRIPTION = "A free software library and application for encoding video streams into the H.265/HEVC format." |
| 3 | HOMEPAGE = "http://www.videolan.org/developers/x265.html" |
| 4 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 5 | LICENSE = "GPL-2.0-only" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 6 | LICENSE_FLAGS = "commercial" |
| 7 | LIC_FILES_CHKSUM = "file://../COPYING;md5=c9e0427bc58f129f99728c62d4ad4091" |
| 8 | |
| 9 | DEPENDS = "nasm-native gnutls zlib libpcre" |
| 10 | |
| 11 | SRC_URI = "http://ftp.videolan.org/pub/videolan/x265/x265_${PV}.tar.gz" |
| 12 | |
| 13 | S = "${WORKDIR}/x265_${PV}/source" |
| 14 | |
| 15 | SRC_URI[md5sum] = "94808045a34d88a857e5eaf3f68f4bca" |
| 16 | SRC_URI[sha256sum] = "fb9badcf92364fd3567f8b5aa0e5e952aeea7a39a2b864387cec31e3b58cbbcc" |
| 17 | |
| 18 | inherit lib_package pkgconfig cmake |
| 19 | |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 20 | do_generate_toolchain_file:append() { |
| 21 | echo "set(CMAKE_ASM_NASM_FLAGS --debug-prefix-map ${S}=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR})" >> ${WORKDIR}/toolchain.cmake |
| 22 | } |
| 23 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 24 | EXTRA_OECMAKE:append:x86 = " -DENABLE_ASSEMBLY=OFF" |
Patrick Williams | 2194f50 | 2022-10-16 14:26:09 -0500 | [diff] [blame] | 25 | EXTRA_OECMAKE:append:aarch64 = " -DENABLE_PIC=ON" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 26 | |
| 27 | AS[unexport] = "1" |
| 28 | |
Patrick Williams | 2194f50 | 2022-10-16 14:26:09 -0500 | [diff] [blame] | 29 | COMPATIBLE_HOST = '(x86_64|i.86|aarch64).*-linux' |