blob: 3462b846d38707773fa6dd91ec28757efd201159 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001# Released under the MIT license (see COPYING.MIT for the terms)
2
3# Applications using this library needs to add link against libbreakpad_client.a.
4
5SUMMARY = "An open-source multi-platform crash reporting system"
6DESCRIPTION = "Breakpad is a library and tool suite that allows you to distribute an application to users with compiler-provided debugging information removed, record crashes in compact \"minidump\" files, send them back to your server, and produce C and C++ stack traces from these minidumps. "
7HOMEPAGE = "https://code.google.com/p/google-breakpad/"
8LICENSE = "BSD-3-Clause"
Andrew Geissler8f840682023-07-21 09:09:43 -05009LIC_FILES_CHKSUM = "file://LICENSE;md5=07aeb530115539d62cacf9942fa60cac"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050010SECTION = "libs"
11
12inherit autotools
13
Andrew Geissler8f840682023-07-21 09:09:43 -050014DEPENDS += "zlib"
Patrick Williams213cb262021-08-07 19:21:33 -050015DEPENDS:append:libc-musl = " libucontext"
Andrew Geissler32b11992021-03-31 13:37:05 -050016
Brad Bishop6e60e8b2018-02-01 10:27:11 -050017BBCLASSEXTEND = "native"
18
Brad Bishop19323692019-04-05 15:28:33 -040019PE = "2"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050020
Brad Bishop19323692019-04-05 15:28:33 -040021PV = "1.0"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050022
Brad Bishopd7bf8c12018-02-25 22:55:05 -050023SRCREV_FORMAT = "breakpad_gtest_protobuf_lss_gyp"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050024
Andrew Geissler8f840682023-07-21 09:09:43 -050025SRCREV_breakpad = "7a1a190f4f68e8a3e06788498f50a4d5520a69f3"
Brad Bishope42b3e32020-01-15 22:08:42 -050026#v1.10.0
Andrew Geissler8f840682023-07-21 09:09:43 -050027SRCREV_gtest = "e2239ee6043f73722e7aa812a459f54a28552929"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050028SRCREV_protobuf = "cb6dd4ef5f82e41e06179dcd57d3b1d9246ad6ac"
Andrew Geissler8f840682023-07-21 09:09:43 -050029SRCREV_lss = "9719c1e1e676814c456b55f5f070eabad6709d31"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050030SRCREV_gyp = "324dd166b7c0b39d513026fa52d6280ac6d56770"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050031
Andrew Geissler595f6302022-01-24 19:11:47 +000032SRC_URI = "git://github.com/google/breakpad;name=breakpad;branch=main;protocol=https \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000033 git://github.com/google/googletest.git;destsuffix=git/src/testing/gtest;name=gtest;branch=main;protocol=https \
Andrew Geissler595f6302022-01-24 19:11:47 +000034 git://github.com/protocolbuffers/protobuf.git;destsuffix=git/src/third_party/protobuf/protobuf;name=protobuf;branch=master;protocol=https \
Andrew Geissler32b11992021-03-31 13:37:05 -050035 git://chromium.googlesource.com/linux-syscall-support;protocol=https;branch=main;destsuffix=git/src/third_party/lss;name=lss \
Andrew Geissler595f6302022-01-24 19:11:47 +000036 git://chromium.googlesource.com/external/gyp;protocol=https;destsuffix=git/src/tools/gyp;name=gyp;branch=master \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050037 file://0001-include-sys-reg.h-to-get-__WORDSIZE-on-musl-libc.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050038 file://0003-Fix-conflict-between-musl-libc-dirent.h-and-lss.patch \
39 file://0001-Turn-off-sign-compare-for-musl-libc.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050040 file://0003-Dont-include-stab.h.patch \
41 file://0004-elf_reader.cc-include-sys-reg.h-to-get-__WORDSIZE-on.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050042 file://mcontext.patch \
Andrew Geissler32b11992021-03-31 13:37:05 -050043 file://0001-Remove-HAVE_GETCONTEXT-check-to-add-local-implementa.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050044 file://0001-lss-Match-syscalls-to-match-musl.patch;patchdir=src/third_party/lss \
45 file://mips_asm_sgidefs.patch;patchdir=src/third_party/lss \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050046"
47S = "${WORKDIR}/git"
48
Brad Bishopd7bf8c12018-02-25 22:55:05 -050049CXXFLAGS += "-D_GNU_SOURCE"
Patrick Williams213cb262021-08-07 19:21:33 -050050LDFLAGS:append:libc-musl = " -lucontext"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050051
Patrick Williams213cb262021-08-07 19:21:33 -050052COMPATIBLE_HOST:powerpc = "null"
53COMPATIBLE_HOST:powerpc64 = "null"
54COMPATIBLE_HOST:powerpc64le = "null"
55COMPATIBLE_HOST:riscv64 = "null"
56COMPATIBLE_HOST:riscv32 = "null"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050057
Patrick Williams213cb262021-08-07 19:21:33 -050058do_install:append() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050059 install -d ${D}${includedir}
60 install -d ${D}${includedir}/breakpad
61
62 install -d ${D}${includedir}/breakpad/client/linux/crash_generation
63 install -m 0644 ${S}/src/client/linux/crash_generation/crash_generation_client.h ${D}${includedir}/breakpad/client/linux/crash_generation/crash_generation_client.h
64
65 install -d ${D}${includedir}/breakpad/client/linux/handler/
66 install -m 0644 ${S}/src/client/linux/handler/exception_handler.h ${D}${includedir}/breakpad/client/linux/handler/exception_handler.h
67 install -m 0644 ${S}/src/client/linux/handler/minidump_descriptor.h ${D}${includedir}/breakpad/client/linux/handler/minidump_descriptor.h
68
69 install -d ${D}${includedir}/breakpad/client/linux/dump_writer_common
70 install -m 0644 ${S}/src/client/linux/dump_writer_common/mapping_info.h ${D}${includedir}/breakpad/client/linux/dump_writer_common/mapping_info.h
71 install -m 0644 ${S}/src/client/linux/dump_writer_common/thread_info.h ${D}${includedir}/breakpad/client/linux/dump_writer_common/thread_info.h
72 install -m 0644 ${S}/src/client/linux/dump_writer_common/raw_context_cpu.h ${D}${includedir}/breakpad/client/linux/dump_writer_common/raw_context_cpu.h
73
74 install -d ${D}${includedir}/breakpad/client/linux/minidump_writer
75 install -m 0644 ${S}/src/client/linux/minidump_writer/linux_dumper.h ${D}${includedir}/breakpad/client/linux/minidump_writer/linux_dumper.h
76 install -m 0644 ${S}/src/client/linux/minidump_writer/minidump_writer.h ${D}${includedir}/breakpad/client/linux/minidump_writer/minidump_writer.h
77
78 install -d ${D}${includedir}/breakpad/common
Brad Bishop19323692019-04-05 15:28:33 -040079 install -m 0644 ${S}/src/common/memory_allocator.h ${D}${includedir}/breakpad/common/memory_allocator.h
Brad Bishop6e60e8b2018-02-01 10:27:11 -050080 install -m 0644 ${S}/src/common/scoped_ptr.h ${D}${includedir}/breakpad/common/scoped_ptr.h
81 install -m 0644 ${S}/src/common/using_std_string.h ${D}${includedir}/breakpad/common/using_std_string.h
82
83 install -d ${D}${includedir}/breakpad/google_breakpad/common
84 install -m 0644 ${S}/src/google_breakpad/common/breakpad_types.h ${D}${includedir}/breakpad/google_breakpad/common/breakpad_types.h
85 install -m 0644 ${S}/src/google_breakpad/common/minidump_format.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_format.h
86 install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_amd64.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_amd64.h
87 install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_arm.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_arm.h
Brad Bishopd7bf8c12018-02-25 22:55:05 -050088 install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_arm64.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_arm64.h
Brad Bishop6e60e8b2018-02-01 10:27:11 -050089 install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_mips.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_mips.h
90 install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_ppc64.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_ppc64.h
91 install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_ppc.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_ppc.h
92 install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_sparc.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_sparc.h
93 install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_x86.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_x86.h
94 install -m 0644 ${S}/src/google_breakpad/common/minidump_exception_linux.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_exception_linux.h
95 install -m 0644 ${S}/src/google_breakpad/common/minidump_exception_mac.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_exception_mac.h
96 install -m 0644 ${S}/src/google_breakpad/common/minidump_exception_ps3.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_exception_ps3.h
97 install -m 0644 ${S}/src/google_breakpad/common/minidump_exception_solaris.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_exception_solaris.h
98 install -m 0644 ${S}/src/google_breakpad/common/minidump_exception_win32.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_exception_win32.h
99
100 install -d ${D}${includedir}/breakpad/third_party/lss
101 install -m 0644 ${S}/src/third_party/lss/linux_syscall_support.h ${D}${includedir}/breakpad/third_party/lss/linux_syscall_support.h
102}
103
104PACKAGES =+ "${PN}-minidump-upload ${PN}-sym-upload"
105
Patrick Williams213cb262021-08-07 19:21:33 -0500106FILES:${PN}-minidump-upload = "${bindir}/minidump_upload"
107FILES:${PN}-sym-upload = "${bindir}/sym_upload"
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500108
109
110SYSROOT_PREPROCESS_FUNCS += "breakpad_populate_sysroot"
111breakpad_populate_sysroot() {
112 sysroot_stage_dir ${D}/usr/include ${SYSROOT_DESTDIR}/usr/include
113 sysroot_stage_dir ${D}/usr/lib ${SYSROOT_DESTDIR}/usr/lib
114 sysroot_stage_dir ${D}/usr/lib ${SYSROOT_DESTDIR}/usr/lib
115}
116
117# Fails to build with thumb-1 (qemuarm)
118#| {standard input}: Assembler messages:
119#| {standard input}:2178: Error: selected processor does not support Thumb mode `it ne'
120#| {standard input}:2179: Error: Thumb does not support conditional execution
121#| {standard input}:2180: Error: selected processor does not support Thumb mode `it eq'
122#| {standard input}:2181: Error: Thumb does not support conditional execution
123#| {standard input}:2183: Error: lo register required -- `str ip,[r1,#-4]!'
124#| {standard input}:2184: Error: Thumb does not support this addressing mode -- `str r6,[r1,#-4]!'
125#| {standard input}:2191: Error: lo register required -- `ldr pc,[sp]'
126#| make: *** [src/client/linux/handler/exception_handler.o] Error 1
Patrick Williams213cb262021-08-07 19:21:33 -0500127ARM_INSTRUCTION_SET:armv5 = "arm"
128ARM_INSTRUCTION_SET:armv4 = "arm"
Brad Bishope42b3e32020-01-15 22:08:42 -0500129
130TOOLCHAIN = "gcc"