Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 2 | |
| 3 | # Applications using this library needs to add link against libbreakpad_client.a. |
| 4 | |
| 5 | SUMMARY = "An open-source multi-platform crash reporting system" |
| 6 | DESCRIPTION = "Breakpad is a library and tool suite that allows you to distribute an application to users with compiler-provided debugging information removed, record crashes in compact \"minidump\" files, send them back to your server, and produce C and C++ stack traces from these minidumps. " |
| 7 | HOMEPAGE = "https://code.google.com/p/google-breakpad/" |
| 8 | LICENSE = "BSD-3-Clause" |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=07aeb530115539d62cacf9942fa60cac" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 10 | SECTION = "libs" |
| 11 | |
| 12 | inherit autotools |
| 13 | |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 14 | DEPENDS += "zlib" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 15 | DEPENDS:append:libc-musl = " libucontext" |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 16 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 17 | BBCLASSEXTEND = "native" |
| 18 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 19 | PE = "2" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 20 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 21 | PV = "1.0" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 22 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 23 | SRCREV_FORMAT = "breakpad_gtest_protobuf_lss_gyp" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 24 | |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 25 | SRCREV_breakpad = "7a1a190f4f68e8a3e06788498f50a4d5520a69f3" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 26 | #v1.10.0 |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 27 | SRCREV_gtest = "e2239ee6043f73722e7aa812a459f54a28552929" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 28 | SRCREV_protobuf = "cb6dd4ef5f82e41e06179dcd57d3b1d9246ad6ac" |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 29 | SRCREV_lss = "9719c1e1e676814c456b55f5f070eabad6709d31" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 30 | SRCREV_gyp = "324dd166b7c0b39d513026fa52d6280ac6d56770" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 31 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 32 | SRC_URI = "git://github.com/google/breakpad;name=breakpad;branch=main;protocol=https \ |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 33 | git://github.com/google/googletest.git;destsuffix=git/src/testing/gtest;name=gtest;branch=main;protocol=https \ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 34 | git://github.com/protocolbuffers/protobuf.git;destsuffix=git/src/third_party/protobuf/protobuf;name=protobuf;branch=master;protocol=https \ |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 35 | git://chromium.googlesource.com/linux-syscall-support;protocol=https;branch=main;destsuffix=git/src/third_party/lss;name=lss \ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 36 | git://chromium.googlesource.com/external/gyp;protocol=https;destsuffix=git/src/tools/gyp;name=gyp;branch=master \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 37 | file://0001-include-sys-reg.h-to-get-__WORDSIZE-on-musl-libc.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 38 | file://0003-Fix-conflict-between-musl-libc-dirent.h-and-lss.patch \ |
| 39 | file://0001-Turn-off-sign-compare-for-musl-libc.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 40 | file://0003-Dont-include-stab.h.patch \ |
| 41 | file://0004-elf_reader.cc-include-sys-reg.h-to-get-__WORDSIZE-on.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 42 | file://mcontext.patch \ |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 43 | file://0001-Remove-HAVE_GETCONTEXT-check-to-add-local-implementa.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 44 | file://0001-lss-Match-syscalls-to-match-musl.patch;patchdir=src/third_party/lss \ |
| 45 | file://mips_asm_sgidefs.patch;patchdir=src/third_party/lss \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 46 | " |
| 47 | S = "${WORKDIR}/git" |
| 48 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 49 | CXXFLAGS += "-D_GNU_SOURCE" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 50 | LDFLAGS:append:libc-musl = " -lucontext" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 51 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 52 | COMPATIBLE_HOST:powerpc = "null" |
| 53 | COMPATIBLE_HOST:powerpc64 = "null" |
| 54 | COMPATIBLE_HOST:powerpc64le = "null" |
| 55 | COMPATIBLE_HOST:riscv64 = "null" |
| 56 | COMPATIBLE_HOST:riscv32 = "null" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 57 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 58 | do_install:append() { |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 59 | install -d ${D}${includedir} |
| 60 | install -d ${D}${includedir}/breakpad |
| 61 | |
| 62 | install -d ${D}${includedir}/breakpad/client/linux/crash_generation |
| 63 | install -m 0644 ${S}/src/client/linux/crash_generation/crash_generation_client.h ${D}${includedir}/breakpad/client/linux/crash_generation/crash_generation_client.h |
| 64 | |
| 65 | install -d ${D}${includedir}/breakpad/client/linux/handler/ |
| 66 | install -m 0644 ${S}/src/client/linux/handler/exception_handler.h ${D}${includedir}/breakpad/client/linux/handler/exception_handler.h |
| 67 | install -m 0644 ${S}/src/client/linux/handler/minidump_descriptor.h ${D}${includedir}/breakpad/client/linux/handler/minidump_descriptor.h |
| 68 | |
| 69 | install -d ${D}${includedir}/breakpad/client/linux/dump_writer_common |
| 70 | install -m 0644 ${S}/src/client/linux/dump_writer_common/mapping_info.h ${D}${includedir}/breakpad/client/linux/dump_writer_common/mapping_info.h |
| 71 | install -m 0644 ${S}/src/client/linux/dump_writer_common/thread_info.h ${D}${includedir}/breakpad/client/linux/dump_writer_common/thread_info.h |
| 72 | install -m 0644 ${S}/src/client/linux/dump_writer_common/raw_context_cpu.h ${D}${includedir}/breakpad/client/linux/dump_writer_common/raw_context_cpu.h |
| 73 | |
| 74 | install -d ${D}${includedir}/breakpad/client/linux/minidump_writer |
| 75 | install -m 0644 ${S}/src/client/linux/minidump_writer/linux_dumper.h ${D}${includedir}/breakpad/client/linux/minidump_writer/linux_dumper.h |
| 76 | install -m 0644 ${S}/src/client/linux/minidump_writer/minidump_writer.h ${D}${includedir}/breakpad/client/linux/minidump_writer/minidump_writer.h |
| 77 | |
| 78 | install -d ${D}${includedir}/breakpad/common |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 79 | install -m 0644 ${S}/src/common/memory_allocator.h ${D}${includedir}/breakpad/common/memory_allocator.h |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 80 | install -m 0644 ${S}/src/common/scoped_ptr.h ${D}${includedir}/breakpad/common/scoped_ptr.h |
| 81 | install -m 0644 ${S}/src/common/using_std_string.h ${D}${includedir}/breakpad/common/using_std_string.h |
| 82 | |
| 83 | install -d ${D}${includedir}/breakpad/google_breakpad/common |
| 84 | install -m 0644 ${S}/src/google_breakpad/common/breakpad_types.h ${D}${includedir}/breakpad/google_breakpad/common/breakpad_types.h |
| 85 | install -m 0644 ${S}/src/google_breakpad/common/minidump_format.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_format.h |
| 86 | install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_amd64.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_amd64.h |
| 87 | install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_arm.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_arm.h |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 88 | install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_arm64.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_arm64.h |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 89 | install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_mips.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_mips.h |
| 90 | install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_ppc64.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_ppc64.h |
| 91 | install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_ppc.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_ppc.h |
| 92 | install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_sparc.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_sparc.h |
| 93 | install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_x86.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_x86.h |
| 94 | install -m 0644 ${S}/src/google_breakpad/common/minidump_exception_linux.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_exception_linux.h |
| 95 | install -m 0644 ${S}/src/google_breakpad/common/minidump_exception_mac.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_exception_mac.h |
| 96 | install -m 0644 ${S}/src/google_breakpad/common/minidump_exception_ps3.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_exception_ps3.h |
| 97 | install -m 0644 ${S}/src/google_breakpad/common/minidump_exception_solaris.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_exception_solaris.h |
| 98 | install -m 0644 ${S}/src/google_breakpad/common/minidump_exception_win32.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_exception_win32.h |
| 99 | |
| 100 | install -d ${D}${includedir}/breakpad/third_party/lss |
| 101 | install -m 0644 ${S}/src/third_party/lss/linux_syscall_support.h ${D}${includedir}/breakpad/third_party/lss/linux_syscall_support.h |
| 102 | } |
| 103 | |
| 104 | PACKAGES =+ "${PN}-minidump-upload ${PN}-sym-upload" |
| 105 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 106 | FILES:${PN}-minidump-upload = "${bindir}/minidump_upload" |
| 107 | FILES:${PN}-sym-upload = "${bindir}/sym_upload" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 108 | |
| 109 | |
| 110 | SYSROOT_PREPROCESS_FUNCS += "breakpad_populate_sysroot" |
| 111 | breakpad_populate_sysroot() { |
| 112 | sysroot_stage_dir ${D}/usr/include ${SYSROOT_DESTDIR}/usr/include |
| 113 | sysroot_stage_dir ${D}/usr/lib ${SYSROOT_DESTDIR}/usr/lib |
| 114 | sysroot_stage_dir ${D}/usr/lib ${SYSROOT_DESTDIR}/usr/lib |
| 115 | } |
| 116 | |
| 117 | # Fails to build with thumb-1 (qemuarm) |
| 118 | #| {standard input}: Assembler messages: |
| 119 | #| {standard input}:2178: Error: selected processor does not support Thumb mode `it ne' |
| 120 | #| {standard input}:2179: Error: Thumb does not support conditional execution |
| 121 | #| {standard input}:2180: Error: selected processor does not support Thumb mode `it eq' |
| 122 | #| {standard input}:2181: Error: Thumb does not support conditional execution |
| 123 | #| {standard input}:2183: Error: lo register required -- `str ip,[r1,#-4]!' |
| 124 | #| {standard input}:2184: Error: Thumb does not support this addressing mode -- `str r6,[r1,#-4]!' |
| 125 | #| {standard input}:2191: Error: lo register required -- `ldr pc,[sp]' |
| 126 | #| make: *** [src/client/linux/handler/exception_handler.o] Error 1 |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 127 | ARM_INSTRUCTION_SET:armv5 = "arm" |
| 128 | ARM_INSTRUCTION_SET:armv4 = "arm" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 129 | |
| 130 | TOOLCHAIN = "gcc" |