Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | # Copyright (C) 2012 Khem Raj <raj.khem@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | SUMMARY = "Linux kernel style configuration framework for other projects" |
| 5 | DESCRIPTION = "The kconfig-frontends project aims at centralising \ |
| 6 | the effort of keeping an up-to-date, out-of-tree, packaging of the \ |
| 7 | kconfig infrastructure, ready for use by third-party projects. \ |
| 8 | The kconfig-frontends package provides the kconfig parser, as well as all \ |
| 9 | the frontends" |
Brad Bishop | 00ab237 | 2019-10-14 11:06:18 -0400 | [diff] [blame] | 10 | HOMEPAGE = "https://gitlab.com/ymorin/kconfig-frontends" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 11 | LICENSE = "GPL-2.0-only" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=9b8cf60ff39767ff04b671fca8302408" |
| 13 | SECTION = "devel" |
Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 14 | DEPENDS += "ncurses flex-native gperf-native bison-native" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 15 | RDEPENDS:${PN} += "python3 bash" |
Brad Bishop | 00ab237 | 2019-10-14 11:06:18 -0400 | [diff] [blame] | 16 | SRC_URI = "git://gitlab.com/ymorin/kconfig-frontends.git;protocol=https;branch=4.11.x \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 17 | file://0001-Makefile-ensure-frontends-exits-before-writing-into-.patch \ |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 18 | file://0001-Switch-utils-kconfig-diff-to-use-Python-3.patch \ |
| 19 | file://0001-Avoid-using-hard-coded-usr-include-paths.patch" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 20 | |
| 21 | SRCREV = "f22fce3a308be1c7790ebefc6bbedb33c5f7c86a" |
| 22 | |
| 23 | S = "${WORKDIR}/git" |
| 24 | |
| 25 | inherit autotools pkgconfig |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 26 | do_configure:prepend () { |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 27 | mkdir -p ${S}/scripts/.autostuff/m4 |
| 28 | } |
| 29 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 30 | do_install:append() { |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 31 | ln -s kconfig-conf ${D}${bindir}/conf |
| 32 | ln -s kconfig-mconf ${D}${bindir}/mconf |
| 33 | } |
| 34 | |
| 35 | EXTRA_OECONF += "--disable-gconf --disable-qconf" |
| 36 | |
| 37 | # Some packages have the version preceeding the .so instead properly |
| 38 | # versioned .so.<version>, so we need to reorder and repackage. |
| 39 | SOLIBS = "-${@d.getVar('PV')[:-2]}.so" |
| 40 | FILES_SOLIBSDEV = "${libdir}/libkconfig-parser.so" |
| 41 | |
| 42 | BBCLASSEXTEND = "native" |