Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 1 | SUMMARY = "Y2038 safe version of wtmp" |
| 2 | HOMEPAGE = "https://github.com/thkukuk/wtmpdb" |
| 3 | DESCRIPTION = "last reports the login and logout times of users and when the machine got rebooted." |
| 4 | LICENSE = "BSD-2-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=020090a00b69dd2af9ab82eb0003ea2c" |
| 6 | SECTION = "libs" |
| 7 | |
| 8 | SRCREV = "502b19a41c7a3b1b5e70969b18088683825f71f8" |
| 9 | |
| 10 | SRC_URI = "git://github.com/thkukuk/wtmpdb.git;branch=main;protocol=https \ |
| 11 | file://0001-remove-lto-to-fix-link-error-of-clang.patch \ |
| 12 | " |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | inherit meson pkgconfig systemd features_check |
| 17 | |
| 18 | DEPENDS += " ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)} sqlite3 " |
| 19 | REQUIRED_DISTRO_FEATURES = "pam" |
| 20 | |
| 21 | SYSTEMD_SERVICE:${PN} = "wtmpdb-update-boot.service wtmpdb-rotate.service" |
| 22 | |
| 23 | EXTRA_OEMESON = " -Dpamlibdir=${libdir}" |
| 24 | |
| 25 | do_install:append () { |
| 26 | if [ -d ${D}${prefix}/lib/systemd -a ${D}${prefix}/lib != `dirname ${D}${systemd_unitdir}` ]; then |
| 27 | # Fix makefile hardcoded path assumptions for systemd (assumes $prefix) |
| 28 | # without usrmerge distro feature enabled |
| 29 | install -d `dirname ${D}${systemd_unitdir}` |
| 30 | mv ${D}${prefix}/lib/systemd `dirname ${D}${systemd_unitdir}` |
| 31 | fi |
| 32 | } |
| 33 | |
| 34 | FILES:${PN} += " ${systemd_system_unitdir} " |
| 35 | FILES:${PN} += " ${libdir} " |
| 36 | FILES:${PN} += " ${nonarch_libdir}/tmpfiles.d/* " |