blob: 2e189ddace0a591bb42edb7d4f204534bd67bde1 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "An adapter to Linux kernel support for inotify directory-watching."
Andrew Geissler517393d2023-01-13 08:55:19 -06002HOMEPAGE = "https://pypi.org/project/inotify/"
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://setup.py;md5=79b7ec72aa0d446a552d3cceb5799e41;beginline=28;endline=28"
5
6SRC_URI[sha256sum] = "974a623a338482b62e16d4eb705fb863ed33ec178680fc3e96ccdf0df6c02a07"
7
8SRC_URI = " \
9 git://github.com/dsoprea/pyinotify.git;branch=master;protocol=https \
Andrew Geissler5082cc72023-09-11 08:41:39 -040010 file://new-test-inotify.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060011 file://run-ptest \
12"
13
14SRCREV = "9be6a51d1660991562eefaaddefa757ca0e0e00f"
15
16S = "${WORKDIR}/git"
17
18inherit setuptools3 ptest
19PIP_INSTALL_PACKAGE = "inotify"
20PIP_INSTALL_DIST_PATH = "${S}/dist"
21
22
23RDEPENDS:${PN} += " \
24 python3-ctypes \
25 python3-logging \
26"
27
28RDEPENDS:${PN}-ptest += " \
29 ${PYTHON_PN}-pytest \
30"
31
32do_install_ptest() {
33 install -d ${D}${PTEST_PATH}/tests
34 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
35}