blob: 4cd3801ee703f95d392fa585a70cf3536a6bece6 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "A fully featured modbus protocol stack in python"
2HOMEPAGE = "https://github.com/riptideio/pymodbus/"
3LICENSE = "BSD-3-Clause"
Andrew Geissler5082cc72023-09-11 08:41:39 -04004LIC_FILES_CHKSUM = "file://LICENSE;md5=6a146397c35e3d0953758ce8803de347"
Andrew Geissler517393d2023-01-13 08:55:19 -06005DEPENDS += "python3-six-native"
6
Andrew Geissler220dafd2023-10-04 10:18:08 -05007SRC_URI[sha256sum] = "26c1aa9919b24f2247794d5d9d80f65ec06fdfd9bd6b76b81d446b55335cabf3"
Andrew Geissler517393d2023-01-13 08:55:19 -06008S = "${WORKDIR}/pymodbus-${PV}"
9
10inherit pypi setuptools3
11
12PACKAGECONFIG ??= ""
13PACKAGECONFIG[repl] = ",,,python3-aiohttp python3-click python3-prompt-toolkit python3-pygments python3-pyserial-asyncio"
14PACKAGECONFIG[asyncio] = ",,,python3-pyserial-asyncio"
15PACKAGECONFIG[tornado] = ",,,python3-tornado"
16PACKAGECONFIG[twisted] = ",,,python3-twisted-conch"
17PACKAGECONFIG[redis] = ",,,python3-redis"
18PACKAGECONFIG[sql] = ",,,python3-sqlalchemy"
19
20RDEPENDS:${PN} += " \
21 python3-asyncio \
22 python3-core \
23 python3-io \
24 python3-json \
25 python3-logging \
26 python3-math \
27 python3-netserver \
28"
29
30RDEPENDS:${PN} += " \
31 python3-pyserial \
32 python3-six \
33"
34
35