blob: 16d433910f8e0b3c5d7f9641d90bf2c0c6afe0cb [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Rust compiler and runtime libaries"
2HOMEPAGE = "http://www.rust-lang.org"
3SECTION = "devel"
4LICENSE = "(MIT | Apache-2.0) & Unicode-TOU"
Patrick Williams864cc432023-02-09 14:54:44 -06005LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=c2cccf560306876da3913d79062a54b9"
Andrew Geissler517393d2023-01-13 08:55:19 -06006
7inherit rust
8inherit cargo_common
9
10DEPENDS += "file-native python3-native"
11DEPENDS:append:class-native = " rust-llvm-native"
12DEPENDS:append:class-nativesdk = " nativesdk-rust-llvm"
13
14DEPENDS += "rust-llvm (=${PV})"
15
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050016RDEPENDS:${PN}:append:class-target = " gcc g++ binutils"
17
Andrew Geissler517393d2023-01-13 08:55:19 -060018# Otherwise we'll depend on what we provide
19INHIBIT_DEFAULT_RUST_DEPS:class-native = "1"
20# We don't need to depend on gcc-native because yocto assumes it exists
21PROVIDES:class-native = "virtual/${TARGET_PREFIX}rust"
22
23S = "${RUSTSRC}"
24
25# Use at your own risk, accepted values are stable, beta and nightly
26RUST_CHANNEL ?= "stable"
27PV .= "${@bb.utils.contains('RUST_CHANNEL', 'stable', '', '-${RUST_CHANNEL}', d)}"
28
29export FORCE_CRATE_HASH="${BB_TASKHASH}"
30
31RUST_ALTERNATE_EXE_PATH ?= "${STAGING_LIBDIR}/llvm-rust/bin/llvm-config"
32RUST_ALTERNATE_EXE_PATH_NATIVE = "${STAGING_LIBDIR_NATIVE}/llvm-rust/bin/llvm-config"
33
34# We don't want to use bitbakes vendoring because the rust sources do their
35# own vendoring.
36CARGO_DISABLE_BITBAKE_VENDORING = "1"
37
38# We can't use RUST_BUILD_SYS here because that may be "musl" if
39# TCLIBC="musl". Snapshots are always -unknown-linux-gnu
40setup_cargo_environment () {
41 # The first step is to build bootstrap and some early stage tools,
42 # these are build for the same target as the snapshot, e.g.
43 # x86_64-unknown-linux-gnu.
44 # Later stages are build for the native target (i.e. target.x86_64-linux)
45 cargo_common_do_configure
46}
47
48inherit rust-target-config
49
50do_rust_setup_snapshot () {
51 for installer in "${WORKDIR}/rust-snapshot-components/"*"/install.sh"; do
52 "${installer}" --prefix="${WORKDIR}/rust-snapshot" --disable-ldconfig
53 done
54
55 # Some versions of rust (e.g. 1.18.0) tries to find cargo in stage0/bin/cargo
56 # and fail without it there.
57 mkdir -p ${RUSTSRC}/build/${BUILD_SYS}
58 ln -sf ${WORKDIR}/rust-snapshot/ ${RUSTSRC}/build/${BUILD_SYS}/stage0
59
60 # Need to use uninative's loader if enabled/present since the library paths
61 # are used internally by rust and result in symbol mismatches if we don't
62 if [ ! -z "${UNINATIVE_LOADER}" -a -e "${UNINATIVE_LOADER}" ]; then
63 for bin in cargo rustc rustdoc; do
64 patchelf-uninative ${WORKDIR}/rust-snapshot/bin/$bin --set-interpreter ${UNINATIVE_LOADER}
65 done
66 fi
67}
68addtask rust_setup_snapshot after do_unpack before do_configure
Andrew Geissler8f840682023-07-21 09:09:43 -050069addtask do_test_compile after do_configure do_rust_gen_targets
Andrew Geissler517393d2023-01-13 08:55:19 -060070do_rust_setup_snapshot[dirs] += "${WORKDIR}/rust-snapshot"
71do_rust_setup_snapshot[vardepsexclude] += "UNINATIVE_LOADER"
72
73python do_configure() {
74 import json
75 try:
76 import configparser
77 except ImportError:
78 import ConfigParser as configparser
79
80 # toml is rather similar to standard ini like format except it likes values
81 # that look more JSON like. So for our purposes simply escaping all values
82 # as JSON seem to work fine.
83
84 e = lambda s: json.dumps(s)
85
86 config = configparser.RawConfigParser()
87
88 # [target.ARCH-poky-linux]
Patrick Williams864cc432023-02-09 14:54:44 -060089 host_section = "target.{}".format(d.getVar('RUST_HOST_SYS'))
Andrew Geissler517393d2023-01-13 08:55:19 -060090 config.add_section(host_section)
91
92 llvm_config_target = d.expand("${RUST_ALTERNATE_EXE_PATH}")
93 llvm_config_build = d.expand("${RUST_ALTERNATE_EXE_PATH_NATIVE}")
94 config.set(host_section, "llvm-config", e(llvm_config_target))
95
96 config.set(host_section, "cxx", e(d.expand("${RUST_TARGET_CXX}")))
97 config.set(host_section, "cc", e(d.expand("${RUST_TARGET_CC}")))
98 config.set(host_section, "linker", e(d.expand("${RUST_TARGET_CCLD}")))
99 if "musl" in host_section:
100 config.set(host_section, "musl-root", e(d.expand("${STAGING_DIR_HOST}${exec_prefix}")))
101
102 # If we don't do this rust-native will compile it's own llvm for BUILD.
103 # [target.${BUILD_ARCH}-unknown-linux-gnu]
Patrick Williams864cc432023-02-09 14:54:44 -0600104 build_section = "target.{}".format(d.getVar('RUST_BUILD_SYS'))
Andrew Geissler517393d2023-01-13 08:55:19 -0600105 if build_section != host_section:
106 config.add_section(build_section)
107
108 config.set(build_section, "llvm-config", e(llvm_config_build))
109
110 config.set(build_section, "cxx", e(d.expand("${RUST_BUILD_CXX}")))
111 config.set(build_section, "cc", e(d.expand("${RUST_BUILD_CC}")))
112 config.set(build_section, "linker", e(d.expand("${RUST_BUILD_CCLD}")))
113
Patrick Williams864cc432023-02-09 14:54:44 -0600114 target_section = "target.{}".format(d.getVar('RUST_TARGET_SYS'))
Andrew Geissler517393d2023-01-13 08:55:19 -0600115 if target_section != host_section and target_section != build_section:
116 config.add_section(target_section)
117
118 config.set(target_section, "llvm-config", e(llvm_config_target))
119
120 config.set(target_section, "cxx", e(d.expand("${RUST_TARGET_CXX}")))
121 config.set(target_section, "cc", e(d.expand("${RUST_TARGET_CC}")))
122 config.set(target_section, "linker", e(d.expand("${RUST_TARGET_CCLD}")))
123
124 # [llvm]
125 config.add_section("llvm")
126 config.set("llvm", "static-libstdcpp", e(False))
127 if "llvm" in (d.getVar('TC_CXX_RUNTIME') or ""):
128 config.set("llvm", "use-libcxx", e(True))
129
130 # [rust]
131 config.add_section("rust")
132 config.set("rust", "rpath", e(True))
Andrew Geissler20137392023-10-12 04:59:14 -0600133 config.set("rust", "remap-debuginfo", e(True))
Andrew Geissler517393d2023-01-13 08:55:19 -0600134 config.set("rust", "channel", e(d.expand("${RUST_CHANNEL}")))
135
136 # Whether or not to optimize the compiler and standard library
137 config.set("rust", "optimize", e(True))
138
139 # Emits extraneous output from tests to ensure that failures of the test
140 # harness are debuggable just from logfiles
141 config.set("rust", "verbose-tests", e(True))
142
143 # [build]
144 config.add_section("build")
145 config.set("build", "submodules", e(False))
146 config.set("build", "docs", e(False))
147
148 rustc = d.expand("${WORKDIR}/rust-snapshot/bin/rustc")
149 config.set("build", "rustc", e(rustc))
150
151 # Support for the profiler runtime to generate e.g. coverage report,
152 # PGO etc.
153 config.set("build", "profiler", e(True))
154
155 cargo = d.expand("${WORKDIR}/rust-snapshot/bin/cargo")
156 config.set("build", "cargo", e(cargo))
157
158 config.set("build", "vendor", e(True))
159
160 if not "targets" in locals():
Patrick Williams864cc432023-02-09 14:54:44 -0600161 targets = [d.getVar("RUST_TARGET_SYS")]
Andrew Geissler517393d2023-01-13 08:55:19 -0600162 config.set("build", "target", e(targets))
163
164 if not "hosts" in locals():
Patrick Williams864cc432023-02-09 14:54:44 -0600165 hosts = [d.getVar("RUST_HOST_SYS")]
Andrew Geissler517393d2023-01-13 08:55:19 -0600166 config.set("build", "host", e(hosts))
167
168 # We can't use BUILD_SYS since that is something the rust snapshot knows
169 # nothing about when trying to build some stage0 tools (like fabricate)
Patrick Williams864cc432023-02-09 14:54:44 -0600170 config.set("build", "build", e(d.getVar("RUST_BUILD_SYS")))
Andrew Geissler517393d2023-01-13 08:55:19 -0600171
172 # [install]
173 config.add_section("install")
174 # ./x.py install doesn't have any notion of "destdir"
175 # but we can prepend ${D} to all the directories instead
Patrick Williams864cc432023-02-09 14:54:44 -0600176 config.set("install", "prefix", e(d.getVar("D") + d.getVar("prefix")))
177 config.set("install", "bindir", e(d.getVar("D") + d.getVar("bindir")))
178 config.set("install", "libdir", e(d.getVar("D") + d.getVar("libdir")))
179 config.set("install", "datadir", e(d.getVar("D") + d.getVar("datadir")))
180 config.set("install", "mandir", e(d.getVar("D") + d.getVar("mandir")))
Andrew Geissler517393d2023-01-13 08:55:19 -0600181
182 with open("config.toml", "w") as f:
183 f.write('changelog-seen = 2\n\n')
184 config.write(f)
185
186 # set up ${WORKDIR}/cargo_home
187 bb.build.exec_func("setup_cargo_environment", d)
188}
189
190rust_runx () {
191 echo "COMPILE ${PN}" "$@"
192
193 # CFLAGS, LDFLAGS, CXXFLAGS, CPPFLAGS are used by rust's build for a
194 # wide range of targets (not just TARGET). Yocto's settings for them will
195 # be inappropriate, avoid using.
196 unset CFLAGS
197 unset LDFLAGS
198 unset CXXFLAGS
199 unset CPPFLAGS
200
201 export RUSTFLAGS="${RUST_DEBUG_REMAP}"
202
203 # Copy the natively built llvm-config into the target so we can run it. Horrible,
204 # but works!
Patrick Williams8e7b46e2023-05-01 14:19:06 -0500205 if [ ${RUST_ALTERNATE_EXE_PATH_NATIVE} != ${RUST_ALTERNATE_EXE_PATH} -a ! -f ${RUST_ALTERNATE_EXE_PATH} ]; then
Andrew Geissler517393d2023-01-13 08:55:19 -0600206 mkdir -p `dirname ${RUST_ALTERNATE_EXE_PATH}`
207 cp ${RUST_ALTERNATE_EXE_PATH_NATIVE} ${RUST_ALTERNATE_EXE_PATH}
208 chrpath -d ${RUST_ALTERNATE_EXE_PATH}
209 fi
210
211 oe_cargo_fix_env
212
213 python3 src/bootstrap/bootstrap.py ${@oe.utils.parallel_make_argument(d, '-j %d')} "$@" --verbose
214}
215rust_runx[vardepsexclude] += "PARALLEL_MAKE"
216
217require rust-source.inc
218require rust-snapshot.inc
219
220INSANE_SKIP:${PN}:class-native = "already-stripped"
221FILES:${PN} += "${libdir}/rustlib"
222FILES:${PN} += "${libdir}/*.so"
223FILES:${PN}-dev = ""
224
225do_compile () {
Andrew Geissler517393d2023-01-13 08:55:19 -0600226}
227
Andrew Geissler8f840682023-07-21 09:09:43 -0500228do_test_compile[dirs] = "${B}"
229do_test_compile () {
230 rust_runx build src/tools/remote-test-server --target "${RUST_TARGET_SYS}"
231}
232
Andrew Geissler517393d2023-01-13 08:55:19 -0600233ALLOW_EMPTY:${PN} = "1"
234
235PACKAGES =+ "${PN}-tools-clippy ${PN}-tools-rustfmt"
236FILES:${PN}-tools-clippy = "${bindir}/cargo-clippy ${bindir}/clippy-driver"
237FILES:${PN}-tools-rustfmt = "${bindir}/rustfmt"
238RDEPENDS:${PN}-tools-clippy = "${PN}"
239RDEPENDS:${PN}-tools-rustfmt = "${PN}"
240
241SUMMARY:${PN}-tools-clippy = "A collection of lints to catch common mistakes and improve your Rust code"
242SUMMARY:${PN}-tools-rustfmt = "A tool for formatting Rust code according to style guidelines"
243
244do_install () {
245 rust_do_install
246}
247
248rust_do_install() {
249 rust_runx install
250}
251
252rust_do_install:class-nativesdk() {
253 export PSEUDO_UNLOAD=1
254 rust_runx install
Patrick Williams8e7b46e2023-05-01 14:19:06 -0500255 rust_runx install clippy
256 rust_runx install rustfmt
Andrew Geissler517393d2023-01-13 08:55:19 -0600257 unset PSEUDO_UNLOAD
258
259 install -d ${D}${bindir}
260 for i in cargo-clippy clippy-driver rustfmt; do
261 cp build/${RUST_BUILD_SYS}/stage2-tools/${RUST_HOST_SYS}/release/$i ${D}${bindir}
262 chrpath -r "\$ORIGIN/../lib" ${D}${bindir}/$i
263 done
264
265 chown root:root ${D}/ -R
266 rm ${D}${libdir}/rustlib/uninstall.sh
267 rm ${D}${libdir}/rustlib/install.log
268 rm ${D}${libdir}/rustlib/manifest*
269}
270
271EXTRA_TOOLS ?= "cargo-clippy clippy-driver rustfmt"
272rust_do_install:class-target() {
273 export PSEUDO_UNLOAD=1
274 rust_runx install
Patrick Williams8e7b46e2023-05-01 14:19:06 -0500275 rust_runx install clippy
276 rust_runx install rustfmt
Andrew Geissler517393d2023-01-13 08:55:19 -0600277 unset PSEUDO_UNLOAD
278
279 install -d ${D}${bindir}
280 for i in ${EXTRA_TOOLS}; do
281 cp build/${RUST_BUILD_SYS}/stage2-tools/${RUST_HOST_SYS}/release/$i ${D}${bindir}
282 chrpath -r "\$ORIGIN/../lib" ${D}${bindir}/$i
283 done
284
285 install -d ${D}${libdir}/rustlib/${RUST_HOST_SYS}
286 install -m 0644 ${WORKDIR}/rust-targets/${RUST_HOST_SYS}.json ${D}${libdir}/rustlib/${RUST_HOST_SYS}/target.json
287
288 chown root:root ${D}/ -R
289 rm ${D}${libdir}/rustlib/uninstall.sh
290 rm ${D}${libdir}/rustlib/install.log
291 rm ${D}${libdir}/rustlib/manifest*
292}
293
Patrick Williams864cc432023-02-09 14:54:44 -0600294addtask do_update_snapshot after do_patch
295do_update_snapshot[nostamp] = "1"
296
297# Run with `bitbake -c update_snapshot rust` to update `rust-snapshot.inc`
298# with the checksums for the rust snapshot associated with this rustc-src
299# tarball.
300python do_update_snapshot() {
301 import json
302 import re
303 import sys
304
305 from collections import defaultdict
306
307 with open(os.path.join(d.getVar("S"), "src", "stage0.json")) as f:
308 j = json.load(f)
309
310 config_dist_server = j['config']['dist_server']
311 compiler_date = j['compiler']['date']
312 compiler_version = j['compiler']['version']
313
314 src_uri = defaultdict(list)
315 for k, v in j['checksums_sha256'].items():
316 m = re.search(f"dist/{compiler_date}/(?P<component>.*)-{compiler_version}-(?P<arch>.*)-unknown-linux-gnu\\.tar\\.xz", k)
317 if m:
318 component = m.group('component')
319 arch = m.group('arch')
320 src_uri[arch].append(f"SRC_URI[{component}-snapshot-{arch}.sha256sum] = \"{v}\"")
321
322 snapshot = """\
323## This is information on the rust-snapshot (binary) used to build our current release.
324## snapshot info is taken from rust/src/stage0.json
325## Rust is self-hosting and bootstraps itself with a pre-built previous version of itself.
326## The exact (previous) version that has been used is specified in the source tarball.
327## The version is replicated here.
328
329SNAPSHOT_VERSION = "%s"
330
331""" % compiler_version
332
333 for arch, components in src_uri.items():
334 snapshot += "\n".join(components) + "\n\n"
335
336 snapshot += """\
337SRC_URI += " \\
338 ${RUST_DIST_SERVER}/dist/${RUST_STD_SNAPSHOT}.tar.xz;name=rust-std-snapshot-${RUST_BUILD_ARCH};subdir=rust-snapshot-components \\
339 ${RUST_DIST_SERVER}/dist/${RUSTC_SNAPSHOT}.tar.xz;name=rustc-snapshot-${RUST_BUILD_ARCH};subdir=rust-snapshot-components \\
340 ${RUST_DIST_SERVER}/dist/${CARGO_SNAPSHOT}.tar.xz;name=cargo-snapshot-${RUST_BUILD_ARCH};subdir=rust-snapshot-components \\
341"
342
343RUST_DIST_SERVER = "%s"
344
345RUST_STD_SNAPSHOT = "rust-std-${SNAPSHOT_VERSION}-${RUST_BUILD_ARCH}-unknown-linux-gnu"
346RUSTC_SNAPSHOT = "rustc-${SNAPSHOT_VERSION}-${RUST_BUILD_ARCH}-unknown-linux-gnu"
347CARGO_SNAPSHOT = "cargo-${SNAPSHOT_VERSION}-${RUST_BUILD_ARCH}-unknown-linux-gnu"
348""" % config_dist_server
349
350 with open(os.path.join(d.getVar("THISDIR"), "rust-snapshot.inc"), "w") as f:
351 f.write(snapshot)
352}
353
Andrew Geissler517393d2023-01-13 08:55:19 -0600354RUSTLIB_DEP:class-nativesdk = ""
355
356# musl builds include libunwind.a
357INSANE_SKIP:${PN} = "staticdev"
358
359BBCLASSEXTEND = "native nativesdk"
Patrick Williams520786c2023-06-25 16:20:36 -0500360
361# Since 1.70.0 upgrade this fails to build with gold:
362# http://errors.yoctoproject.org/Errors/Details/708196/
363# ld: error: version script assignment of to symbol __rust_alloc_error_handler_should_panic failed: symbol not defined
364LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd', '', d)}"