blob: d8dd3d6dae953fc7b0c5da0bd553b6f2f4f00936 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "WebKit based web browser for GNOME"
2DESCRIPTION = "Epiphany is an open source web browser for the Linux desktop environment. \
3It provides a simple and easy-to-use internet browsing experience."
4HOMEPAGE = "https://wiki.gnome.org/Apps/Web"
5BUGTRACKER = "https://gitlab.gnome.org/GNOME/epiphany"
6LICENSE = "GPL-3.0-or-later"
7LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
8
9DEPENDS = " \
10 webkitgtk \
Patrick Williams2a254922023-08-11 09:48:11 -050011 gcr \
Andrew Geissler517393d2023-01-13 08:55:19 -060012 gsettings-desktop-schemas \
13 nettle \
14 json-glib \
Patrick Williams2a254922023-08-11 09:48:11 -050015 libadwaita \
Andrew Geissler517393d2023-01-13 08:55:19 -060016 libarchive \
17 libdazzle \
18 libhandy \
19 libportal \
20 libsoup \
21 glib-2.0-native \
22 coreutils-native \
23 desktop-file-utils-native \
24 "
25
26GNOMEBASEBUILDCLASS = "meson"
27inherit gnomebase gsettings features_check gettext mime-xdg gtk-icon-cache
28REQUIRED_DISTRO_FEATURES = "x11 opengl"
29
30SRC_URI = "${GNOME_MIRROR}/${GNOMEBN}/${@oe.utils.trim_version("${PV}", 1)}/${GNOMEBN}-${PV}.tar.${GNOME_COMPRESS_TYPE};name=archive \
31 file://0002-help-meson.build-disable-the-use-of-yelp.patch \
32 file://migrator.patch \
33 file://distributor.patch \
34 "
Patrick Williams2a254922023-08-11 09:48:11 -050035SRC_URI[archive.sha256sum] = "5335dd573581db61e126d854dc16ae519657a5b8790789a47d25e43e17cd3a43"
Andrew Geissler517393d2023-01-13 08:55:19 -060036
37# Developer mode enables debugging
38PACKAGECONFIG[developer-mode] = "-Ddeveloper_mode=true,-Ddeveloper_mode=false"
39
40FILES:${PN} += "${datadir}/dbus-1 ${datadir}/gnome-shell/search-providers ${datadir}/metainfo"
41RDEPENDS:${PN} = "iso-codes adwaita-icon-theme gsettings-desktop-schemas"
Andrew Geissler8f840682023-07-21 09:09:43 -050042
43# ANGLE requires SSE support as of webkit 2.40.x on 32 bit x86
44COMPATIBLE_HOST:x86 = "${@bb.utils.contains_any('TUNE_FEATURES', 'core2 corei7', '.*', 'null', d)}"