Deepak Kodihalli | 14c47d2 | 2017-03-17 03:51:13 -0500 | [diff] [blame] | 1 | SUMMARY = "Open POWER DBus Interfaces" |
| 2 | DESCRIPTION = "Generated bindings, using sdbus++, for the openpower YAML" |
| 3 | PR = "r1" |
Patrick Venture | 92feebc | 2018-10-02 19:51:03 -0700 | [diff] [blame] | 4 | PV = "1.0+git${SRCPV}" |
Patrick Venture | f9afb7a | 2018-11-03 09:10:39 -0700 | [diff] [blame] | 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
Deepak Kodihalli | 14c47d2 | 2017-03-17 03:51:13 -0500 | [diff] [blame] | 7 | |
| 8 | S = "${WORKDIR}/git" |
| 9 | |
| 10 | inherit autotools pkgconfig |
Deepak Kodihalli | 14c47d2 | 2017-03-17 03:51:13 -0500 | [diff] [blame] | 11 | inherit pythonnative |
Marri Devender Rao | 8dd7798 | 2017-05-29 01:33:26 -0500 | [diff] [blame] | 12 | inherit phosphor-dbus-yaml |
Deepak Kodihalli | 14c47d2 | 2017-03-17 03:51:13 -0500 | [diff] [blame] | 13 | |
| 14 | DEPENDS += "autoconf-archive-native" |
| 15 | DEPENDS += "sdbus++-native" |
Matt Spinler | 47c4ef4 | 2019-07-25 11:00:49 -0500 | [diff] [blame] | 16 | DEPENDS += "phosphor-dbus-interfaces" |
Deepak Kodihalli | 14c47d2 | 2017-03-17 03:51:13 -0500 | [diff] [blame] | 17 | |
Deepak Kodihalli | 14c47d2 | 2017-03-17 03:51:13 -0500 | [diff] [blame] | 18 | SRC_URI += "git://github.com/openbmc/openpower-dbus-interfaces" |
Brad Bishop | 2026e88 | 2020-01-09 15:40:15 -0500 | [diff] [blame^] | 19 | SRCREV = "109ded04f3fec7bbbd93f9c9956a355f4894a51f" |
Deepak Kodihalli | 14c47d2 | 2017-03-17 03:51:13 -0500 | [diff] [blame] | 20 | |
| 21 | DEPENDS_remove_class-native = "sdbus++-native" |
| 22 | DEPENDS_remove_class-nativesdk = "sdbus++-native" |
| 23 | |
| 24 | PACKAGECONFIG ??= "libopenpower_dbus" |
| 25 | PACKAGECONFIG[libopenpower_dbus] = " \ |
| 26 | --enable-libopenpower_dbus, \ |
| 27 | --disable-libopenpower_dbus, \ |
| 28 | systemd sdbusplus, \ |
| 29 | libsystemd sdbusplus \ |
| 30 | " |
| 31 | |
| 32 | PACKAGECONFIG_remove_class-native = "libopenpower_dbus" |
| 33 | PACKAGECONFIG_remove_class-nativesdk = "libopenpower_dbus" |
| 34 | |
| 35 | BBCLASSEXTEND += "native nativesdk" |