Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "Library of utility functions from BSD systems" |
| 2 | DESCRIPTION = "This library provides useful functions commonly found on BSD systems, \ |
| 3 | and lacking on others like GNU systems, thus making it easier to port \ |
| 4 | projects with strong BSD origins, without needing to embed the same \ |
| 5 | code over and over again on each project." |
| 6 | |
| 7 | HOMEPAGE = "https://libbsd.freedesktop.org/wiki/" |
| 8 | # There seems to be more licenses used in the code, I don't think we want to list them all here, complete list: |
| 9 | # OE @ ~/projects/libbsd $ grep ^License: COPYING | sort -u |
| 10 | # License: BSD-2-clause |
| 11 | # License: BSD-2-clause-NetBSD |
| 12 | # License: BSD-2-clause-author |
| 13 | # License: BSD-2-clause-verbatim |
| 14 | # License: BSD-3-clause |
| 15 | # License: BSD-3-clause-author |
| 16 | # License: BSD-3-clause-John-Birrell |
| 17 | # License: BSD-3-clause-Regents |
| 18 | # License: BSD-4-clause-Christopher-G-Demetriou |
| 19 | # License: BSD-4-clause-Niels-Provos |
| 20 | # License: BSD-5-clause-Peter-Wemm |
| 21 | # License: Beerware |
| 22 | # License: Expat |
| 23 | # License: ISC |
| 24 | # License: ISC-Original |
| 25 | # License: public-domain |
| 26 | # License: public-domain-Colin-Plumb |
| 27 | LICENSE = "BSD-3-Clause & BSD-4-Clause & ISC & PD" |
| 28 | LICENSE:${PN} = "BSD-3-Clause & ISC & PD" |
Andrew Geissler | 028142b | 2023-05-05 11:29:21 -0500 | [diff] [blame] | 29 | LICENSE:${PN}-dbg = "BSD-3-Clause & ISC & PD" |
| 30 | LICENSE:${PN}-dev = "BSD-3-Clause & ISC & PD" |
| 31 | LICENSE:${PN}-doc = "BSD-3-Clause & BSD-4-Clause & ISC & PD" |
| 32 | LICENSE:${PN}-locale = "BSD-3-Clause & ISC & PD" |
| 33 | LICENSE:${PN}-src = "BSD-3-Clause & ISC & PD" |
| 34 | LICENSE:${PN}-staticdev = "BSD-3-Clause & ISC & PD" |
| 35 | |
Patrick Williams | b58112e | 2024-03-07 11:16:36 -0600 | [diff] [blame] | 36 | LIC_FILES_CHKSUM = "file://COPYING;md5=9b087a0981a1fcad42efbba6d4925a0f" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 37 | SECTION = "libs" |
| 38 | |
Patrick Williams | 56b44a9 | 2024-01-19 08:49:29 -0600 | [diff] [blame] | 39 | SRC_URI = "https://libbsd.freedesktop.org/releases/${BPN}-${PV}.tar.xz" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 40 | |
Patrick Williams | 44b3caf | 2024-04-12 16:51:14 -0500 | [diff] [blame] | 41 | SRC_URI[sha256sum] = "b88cc9163d0c652aaf39a99991d974ddba1c3a9711db8f1b5838af2a14731014" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 42 | |
| 43 | inherit autotools pkgconfig |
| 44 | |
| 45 | DEPENDS += "libmd" |
| 46 | |
| 47 | BBCLASSEXTEND = "native nativesdk" |