Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Maintenance tools for OverlayFS" |
| 2 | HOMEPAGE = "https://github.com/kmxz/overlayfs-tools" |
| 3 | LICENSE = "WTFPL" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=f312a7c4d02230e8f2b537295d375c69" |
| 5 | |
| 6 | SRC_URI = "\ |
| 7 | git://github.com/kmxz/overlayfs-tools.git;protocol=https;branch=master \ |
| 8 | file://0001-Fixed-includes-so-that-it-compiles-on-Ubuntu-20.04.patch \ |
| 9 | file://0002-makefile-fix-linking-flags.patch \ |
| 10 | " |
| 11 | |
| 12 | PV = "1.0+git${SRCPV}" |
| 13 | SRCREV = "291c7f4a3fb548d06c572700650c2e3bccb0cd27" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | B = "${S}" |
| 17 | |
| 18 | DEPENDS += "attr" |
| 19 | # Required to have the fts.h header for musl |
| 20 | DEPENDS:append:libc-musl = " fts" |
| 21 | |
| 22 | EXTRA_OEMAKE += "'CC=${CC} -O2'" |
| 23 | # Fix the missing fts libs when using musl |
| 24 | EXTRA_OEMAKE:append:libc-musl = " LDLIBS=-lfts" |
| 25 | TARGET_CC_ARCH += "${LDFLAGS}" |
| 26 | |
| 27 | do_compile () { |
| 28 | oe_runmake |
| 29 | } |
| 30 | |
| 31 | do_install () { |
| 32 | install -d ${D}${bindir} |
| 33 | install -m 0755 ${B}/overlay ${D}${bindir} |
| 34 | } |