blob: 36c7403856c938ba0f0a34cb6a797c152521ca11 [file] [log] [blame]
Jeremy Kerr882199e2016-03-17 17:35:27 +08001SUMMARY = "OpenBMC console daemon"
2DESCRIPTION = "Daemon to handle UART console connections"
3HOMEPAGE = "http://github.com/openbmc/obmc-console"
4PR = "r1"
5
6inherit obmc-phosphor-license
7inherit obmc-phosphor-systemd
8inherit autotools
9
10TARGET_CFLAGS += "-fpic -O2"
11
Matthew Barth3e20a722016-09-26 16:26:27 -050012DEPENDS += "autoconf-archive-native"
13
Jeremy Kerr882199e2016-03-17 17:35:27 +080014SRC_URI += "git://github.com/openbmc/obmc-console"
Brad Bishopf75c9602016-08-30 14:14:24 -040015SRC_URI += "file://${PN}.conf"
Jeremy Kerr2a9a9d72016-04-12 13:10:12 +080016
Patrick Williams248a54f2016-09-28 08:00:04 -050017SRCREV = "44580de4e2170c8ee06dbf401315d3acfcf52b22"
Jeremy Kerr882199e2016-03-17 17:35:27 +080018
Brad Bishopf75c9602016-08-30 14:14:24 -040019SYSTEMD_SERVICE_${PN} = " \
20 ${PN}.service \
21 ${PN}-ssh.socket \
22 ${PN}-ssh@.service \
23 "
Jeremy Kerr2a9a9d72016-04-12 13:10:12 +080024
Jeremy Kerr882199e2016-03-17 17:35:27 +080025do_install_append() {
26 install -m 0755 -d ${D}${sysconfdir}
27 install -m 0644 ${WORKDIR}/${PN}.conf ${D}${sysconfdir}/${PN}.conf
Jeremy Kerr882199e2016-03-17 17:35:27 +080028}
29
30S = "${WORKDIR}/git"