Chanh Nguyen | 2fc68eb | 2022-04-28 09:11:28 +0000 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC Platform Init Service" |
| 2 | DESCRIPTION = "Phosphor OpenBMC Platform Init Daemon" |
| 3 | |
| 4 | PR = "r1" |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 7 | |
| 8 | inherit systemd |
| 9 | inherit obmc-phosphor-systemd |
| 10 | |
| 11 | DEPENDS += "systemd" |
| 12 | RDEPENDS:${PN} += "libsystemd" |
| 13 | RDEPENDS:${PN} += "bash" |
| 14 | |
| 15 | SRC_URI = " \ |
| 16 | file://ampere-platform-init.service \ |
| 17 | file://ampere-bmc-heartbeat.service \ |
| 18 | file://ampere_platform_init.sh \ |
| 19 | file://ampere_bmc_heartbeat.sh \ |
Hieu Huynh | b953dc9 | 2022-09-12 18:35:36 +0700 | [diff] [blame] | 20 | file://mtmitchell_platform_gpios_init.sh \ |
Chanh Nguyen | 2fc68eb | 2022-04-28 09:11:28 +0000 | [diff] [blame] | 21 | file://gpio-lib.sh \ |
| 22 | " |
| 23 | SYSTEMD_PACKAGES = "${PN}" |
| 24 | SYSTEMD_SERVICE:${PN} = "ampere-platform-init.service ampere-bmc-heartbeat.service" |
| 25 | |
| 26 | do_install () { |
| 27 | install -d ${D}${sbindir} |
| 28 | install -m 0755 ${WORKDIR}/gpio-lib.sh ${D}${sbindir}/ |
| 29 | install -m 0755 ${WORKDIR}/ampere_platform_init.sh ${D}${sbindir}/ |
| 30 | install -m 0755 ${WORKDIR}/ampere_bmc_heartbeat.sh ${D}${sbindir}/ |
Hieu Huynh | b953dc9 | 2022-09-12 18:35:36 +0700 | [diff] [blame] | 31 | install -m 0755 ${WORKDIR}/mtmitchell_platform_gpios_init.sh ${D}${sbindir}/platform_gpios_init.sh |
Chanh Nguyen | 2fc68eb | 2022-04-28 09:11:28 +0000 | [diff] [blame] | 32 | install -d ${D}${systemd_unitdir}/system/ |
| 33 | install -m 0644 ${WORKDIR}/ampere-platform-init.service ${D}${systemd_unitdir}/system |
| 34 | } |
| 35 | |