Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 1 | SUMMARY = "This is a filesystem client based on the HTTP using FUSE" |
| 2 | HOMEPAGE = "http://httpfs.sourceforge.net" |
| 3 | LICENSE = "GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://debian/copyright;md5=83f224c5182f148ec92e0b9f84b3c6c7" |
| 5 | |
| 6 | inherit pkgconfig |
| 7 | |
| 8 | DEPENDS += "fuse" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 9 | RDEPENDS:${PN} += "fuse" |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 10 | |
| 11 | SRC_URI += "https://astuteinternet.dl.sourceforge.net/project/httpfs/httpfs2/httpfs2-${PV}.tar.gz" |
| 12 | SRC_URI[sha256sum] = "01cb4bb38deb344f540da6f1464dc7edbdeb51213ad810b8c9c282c1e17e0fc1" |
| 13 | |
| 14 | S = "${WORKDIR}/httpfs2-${PV}" |
| 15 | |
| 16 | do_compile() { |
| 17 | cd ${S} |
| 18 | oe_runmake httpfs2 |
| 19 | } |
| 20 | |
| 21 | do_install() { |
| 22 | cd ${S} |
| 23 | install -d ${D}${bindir} |
| 24 | install -m 0755 httpfs2 ${D}${bindir} |
| 25 | } |