Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 1 | DESCRIPTION = "Blueman is a GTK+ Bluetooth Manager" |
| 2 | LICENSE = "GPLv3" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 4 | |
| 5 | DEPENDS = "bluez5 python3-pygobject python3-cython-native python3-setuptools-native intltool-native" |
| 6 | |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 7 | inherit autotools gettext systemd gsettings python3native gtk-icon-cache |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 8 | |
| 9 | SRC_URI = " \ |
| 10 | https://github.com/blueman-project/blueman/releases/download/${PV}/blueman-${PV}.tar.xz \ |
| 11 | file://0001-Search-for-cython3.patch \ |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 12 | file://0002-fix-fail-to-enable-bluetooth.patch \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 13 | " |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 14 | SRC_URI[sha256sum] = "fcc10a2259bef2c5ac63f577010d76caed460d68810b7f70fecf056bf10a1a72" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 15 | |
| 16 | EXTRA_OECONF = " \ |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 17 | --disable-appindicator \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 18 | --disable-runtime-deps-check \ |
| 19 | --disable-schemas-compile \ |
| 20 | " |
| 21 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 22 | SYSTEMD_SERVICE:${PN} = "${BPN}-mechanism.service" |
| 23 | SYSTEMD_AUTO_ENABLE:${PN} = "disable" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 24 | |
| 25 | RRECOMENDS_${PN} += "adwaita-icon-theme" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 26 | RDEPENDS:${PN} += " \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 27 | python3-core \ |
| 28 | python3-dbus \ |
| 29 | packagegroup-tools-bluetooth \ |
| 30 | " |
| 31 | |
| 32 | PACKAGECONFIG ??= "thunar" |
| 33 | PACKAGECONFIG[thunar] = "--enable-thunar-sendto,--disable-thunar-sendto" |
| 34 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 35 | FILES:${PN} += " \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 36 | ${datadir}/dbus-1 \ |
| 37 | ${datadir}/Thunar \ |
| 38 | ${systemd_user_unitdir} \ |
| 39 | ${exec_prefix}${systemd_system_unitdir} \ |
| 40 | ${PYTHON_SITEPACKAGES_DIR} \ |
| 41 | " |
| 42 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 43 | FILES:${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/_blueman.a" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 44 | |
| 45 | # In code, path to python is a variable that is replaced with path to native version of it |
| 46 | # during the configure stage, e.g ../recipe-sysroot-native/usr/bin/python3-native/python3. |
| 47 | # Replace it with #!/usr/bin/env python3 |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 48 | do_install:append() { |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 49 | sed -i "1s/.*/#!\/usr\/bin\/env python3/" ${D}${prefix}/libexec/blueman-rfcomm-watcher \ |
| 50 | ${D}${prefix}/libexec/blueman-mechanism \ |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 51 | ${D}${bindir}/blueman-adapters \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 52 | ${D}${bindir}/blueman-applet \ |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 53 | ${D}${bindir}/blueman-manager \ |
| 54 | ${D}${bindir}/blueman-sendto \ |
| 55 | ${D}${bindir}/blueman-services \ |
| 56 | ${D}${bindir}/blueman-tray |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 57 | } |