Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 1 | SUMMARY = "Open source iec61850 implementation" |
| 2 | DESCRIPTION = "IEC 61850 is an international standard for \ |
| 3 | communication systems in Substation Automation Systems \ |
| 4 | (SAS) and management of Decentralized Energy Resources \ |
| 5 | (DER). It is seen as one of the communication standards \ |
| 6 | of the emerging Smart Grid. \ |
| 7 | The project libIEC61850 provides a server and client \ |
| 8 | library for the IEC 61850/MMS, IEC 61850/GOOSE and IEC \ |
| 9 | 61850-9-2/Sampled Values communication protocols \ |
| 10 | written in C. It is available under the GPLv3 license." |
| 11 | HOMEPAGE = "http://libiec61850.com" |
| 12 | SECTION = "console/network" |
| 13 | LICENSE = "GPLv3" |
| 14 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 15 | DEPENDS = "swig-native python3" |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 16 | SRCREV = "fcefc746fea286aeaa40d2f62240216da81c85e5" |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 17 | |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 18 | SRC_URI = "git://github.com/mz-automation/${BPN}.git;branch=v1.5 \ |
| 19 | file://0001-pyiec61850-don-t-break-CMAKE_INSTALL_PATH-by-trying-.patch \ |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 20 | " |
| 21 | |
| 22 | S = "${WORKDIR}/git" |
| 23 | |
| 24 | inherit cmake pkgconfig python3-dir python3native siteinfo |
| 25 | |
| 26 | EXTRA_OECMAKE = " \ |
| 27 | -DBUILD_EXAMPLES=OFF \ |
| 28 | -DBUILD_PYTHON_BINDINGS=ON \ |
| 29 | " |
| 30 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 31 | RDEPENDS:${PN}-python = " python3-core " |
| 32 | RDEPENDS:${PN} = " python3-core " |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 33 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 34 | FILES:${PN} += " \ |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 35 | ${libdir}/${PYTHON_DIR}/site-packages/iec61850.py \ |
| 36 | ${libdir}/${PYTHON_DIR}/site-packages/_iec61850.so \ |
| 37 | " |