Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "A fully-featured http proxy and web-cache daemon for Linux" |
| 2 | DESCRIPTION = "A fully-featured http proxy and web-cache daemon for Linux. \ |
| 3 | Squid offers a rich access control, authorization and logging environment to \ |
| 4 | develop web proxy and content serving applications. \ |
| 5 | Squid offers a rich set of traffic optimization options, most of which are \ |
| 6 | enabled by default for simpler installation and high performance. \ |
| 7 | " |
| 8 | HOMEPAGE = "http://www.squid-cache.org" |
| 9 | SECTION = "web" |
| 10 | LICENSE = "GPLv2+" |
| 11 | |
| 12 | MAJ_VER = "${@oe.utils.trim_version("${PV}", 1)}" |
| 13 | MIN_VER = "${@oe.utils.trim_version("${PV}", 2)}" |
| 14 | |
| 15 | SRC_URI = "http://www.squid-cache.org/Versions/v${MAJ_VER}/${BPN}-${PV}.tar.bz2 \ |
| 16 | file://Set-up-for-cross-compilation.patch \ |
| 17 | file://Skip-AC_RUN_IFELSE-tests.patch \ |
| 18 | file://Fix-flawed-dynamic-ldb-link-test-in-configure.patch \ |
| 19 | file://squid-use-serial-tests-config-needed-by-ptest.patch \ |
| 20 | file://run-ptest \ |
| 21 | file://volatiles.03_squid \ |
| 22 | file://set_sysroot_patch.patch \ |
| 23 | file://squid-don-t-do-squid-conf-tests-at-build-time.patch \ |
| 24 | file://0001-configure-Check-for-Wno-error-format-truncation-comp.patch \ |
| 25 | file://0001-tools.cc-fixed-unused-result-warning.patch \ |
| 26 | file://0001-splay.cc-fix-bind-is-not-a-member-of-std.patch \ |
Andrew Geissler | 97771a3 | 2021-03-05 15:23:11 -0600 | [diff] [blame] | 27 | file://0001-Fix-build-on-Fedora-Rawhide-772.patch \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 28 | " |
| 29 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 30 | SRC_URI:remove:toolchain-clang = "file://0001-configure-Check-for-Wno-error-format-truncation-comp.patch" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 31 | |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 32 | SRC_URI[sha256sum] = "71635811e766ce8b155225a9e3c7757cfc7ff93df26b28d82e5e6fc021b9a605" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 33 | |
| 34 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
Andrew Geissler | 97771a3 | 2021-03-05 15:23:11 -0600 | [diff] [blame] | 35 | file://errors/COPYRIGHT;md5=0e03cd976052c45697ad5d96e7dff8dc \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 36 | " |
| 37 | DEPENDS = "libtool krb5 openldap db cyrus-sasl" |
| 38 | |
| 39 | inherit autotools pkgconfig useradd ptest perlnative |
| 40 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 41 | LDFLAGS:append:mipsarch = " -latomic" |
| 42 | LDFLAGS:append:powerpc = " -latomic" |
| 43 | LDFLAGS:append:riscv64 = " -latomic" |
| 44 | LDFLAGS:append:riscv32 = " -latomic" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 45 | |
| 46 | USERADD_PACKAGES = "${PN}" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 47 | USERADD_PARAM:${PN} = "--system --no-create-home --home-dir /var/run/squid --shell /bin/false --user-group squid" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 48 | |
| 49 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \ |
| 50 | " |
| 51 | PACKAGECONFIG[libnetfilter-conntrack] = "--with-netfilter-conntrack=${includedir}, --without-netfilter-conntrack, libnetfilter-conntrack" |
| 52 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," |
| 53 | PACKAGECONFIG[werror] = "--enable-strict-error-checking,--disable-strict-error-checking," |
| 54 | PACKAGECONFIG[esi] = "--enable-esi,--disable-esi,expat libxml2" |
| 55 | PACKAGECONFIG[ssl] = "--with-openssl=yes,--with-openssl=no,openssl" |
| 56 | |
| 57 | BASIC_AUTH = "DB SASL LDAP" |
| 58 | |
| 59 | DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" |
| 60 | BASIC_AUTH += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'PAM', '', d)}" |
| 61 | |
| 62 | EXTRA_OECONF += "--with-default-user=squid --enable-auth-basic='${BASIC_AUTH}' \ |
| 63 | --sysconfdir=${sysconfdir}/${BPN} \ |
| 64 | --with-logdir=${localstatedir}/log/${BPN} \ |
| 65 | 'PERL=${USRBINPATH}/env perl'" |
| 66 | |
| 67 | export BUILDCXXFLAGS="${BUILD_CXXFLAGS}" |
| 68 | |
| 69 | TESTDIR = "test-suite" |
| 70 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 71 | do_configure:prepend() { |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 72 | export SYSROOT=$PKG_CONFIG_SYSROOT_DIR |
| 73 | } |
| 74 | |
| 75 | do_compile_ptest() { |
| 76 | oe_runmake -C ${TESTDIR} buildtest-TESTS |
| 77 | } |
| 78 | |
| 79 | do_install_ptest() { |
| 80 | cp -rf ${B}/${TESTDIR} ${D}${PTEST_PATH} |
| 81 | cp -rf ${S}/${TESTDIR} ${D}${PTEST_PATH} |
| 82 | |
| 83 | # do NOT need to rebuild Makefile itself |
| 84 | sed -i 's/^Makefile:.*$/Makefile:/' ${D}${PTEST_PATH}/${TESTDIR}/Makefile |
| 85 | |
| 86 | # Add squid-conf-tests for runtime tests |
| 87 | sed -e 's/^\(runtest-TESTS:\)/\1 squid-conf-tests/' \ |
| 88 | -e "s/\(list=' \$(TESTS)\)/\1 squid-conf-tests/" \ |
| 89 | -i ${D}${PTEST_PATH}/${TESTDIR}/Makefile |
| 90 | |
| 91 | # Ensure the path for command true is correct |
| 92 | sed -i 's:^TRUE = .*$:TRUE = /bin/true:' ${D}${PTEST_PATH}/${TESTDIR}/Makefile |
| 93 | } |
| 94 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 95 | do_install:append() { |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 96 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then |
| 97 | install -d ${D}${sysconfdir}/tmpfiles.d |
| 98 | echo "d ${localstatedir}/run/${BPN} 0755 squid squid -" >> ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf |
| 99 | echo "d ${localstatedir}/log/${BPN} 0750 squid squid -" >> ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf |
| 100 | fi |
| 101 | |
| 102 | install -d ${D}${sysconfdir}/default/volatiles |
| 103 | install -m 0644 ${WORKDIR}/volatiles.03_squid ${D}${sysconfdir}/default/volatiles/03_squid |
| 104 | |
| 105 | rmdir "${D}${localstatedir}/run/${BPN}" |
| 106 | rmdir --ignore-fail-on-non-empty "${D}${localstatedir}/run" |
| 107 | |
| 108 | rmdir "${D}${localstatedir}/log/${BPN}" |
| 109 | rmdir --ignore-fail-on-non-empty "${D}${localstatedir}/log" |
| 110 | } |
| 111 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 112 | FILES:${PN} += "${libdir} ${datadir}/errors ${datadir}/icons" |
| 113 | FILES:${PN}-dbg += "/usr/src/debug" |
| 114 | FILES:${PN}-doc += "${datadir}/*.txt" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 115 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 116 | RDEPENDS:${PN} += "perl" |
| 117 | RDEPENDS:${PN}-ptest += "make" |