Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Lossless compression library and tool" |
Andrew Geissler | eafcbb8 | 2020-06-05 17:59:17 -0500 | [diff] [blame] | 2 | DESCRIPTION = "Brotli is a generic-purpose lossless compression algorithm \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 3 | that it is similar in speed to deflate but offers more dense compression." |
| 4 | HOMEPAGE = "https://github.com/google/brotli" |
| 5 | BUGTRACKER = "https://github.com/google/brotli/issues" |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=941ee9cd1609382f946352712a319b4b" |
| 8 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 9 | SRC_URI = "git://github.com/google/brotli.git \ |
| 10 | file://838.patch " |
| 11 | # tag 1.0.9 |
| 12 | SRCREV= "e61745a6b7add50d380cfd7d3883dd6c62fc2c71" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | inherit cmake lib_package |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 16 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 17 | do_install:append () { |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 18 | for lib in $(ls ${D}${libdir}/*-static.a); do |
| 19 | mv -v "${lib}" "$(echo ${lib} | sed s/-static//)" |
| 20 | done |
| 21 | } |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 22 | |
| 23 | BBCLASSEXTEND = "native" |