Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "An abstraction layer for touchscreen panel events" |
| 2 | DESCRIPTION = "Tslib is an abstraction layer for touchscreen panel \ |
| 3 | events, as well as a filter stack for the manipulation of those events. \ |
| 4 | Tslib is generally used on embedded devices to provide a common user \ |
| 5 | space interface to touchscreen functionality." |
| 6 | HOMEPAGE = "http://tslib.org/" |
| 7 | |
| 8 | AUTHOR = "Martin Kepplinger <martink@posteo.de>" |
| 9 | SECTION = "base" |
| 10 | LICENSE = "LGPLv2+ & GPLv2+" |
| 11 | LIC_FILES_CHKSUM = "\ |
| 12 | file://COPYING;md5=fc178bcd425090939a8b634d1d6a9594 \ |
| 13 | file://tests/COPYING;md5=a23a74b3f4caf9616230789d94217acb \ |
| 14 | " |
| 15 | |
| 16 | SRC_URI = "https://github.com/kergoth/tslib/releases/download/${PV}/tslib-${PV}.tar.xz;downloadfilename=tslib-${PV}.tar.xz \ |
| 17 | file://ts.conf \ |
| 18 | file://tslib.sh \ |
Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 19 | " |
| 20 | SRC_URI[sha256sum] = "aaf0aed410a268d7b51385d07fe4d9d64312038e87c447ec8a24c8db0a15617a" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 21 | |
| 22 | UPSTREAM_CHECK_URI = "https://github.com/kergoth/tslib/releases" |
| 23 | |
| 24 | inherit autotools pkgconfig |
| 25 | |
Andrew Geissler | f103a7f | 2021-05-07 16:09:40 -0500 | [diff] [blame] | 26 | PACKAGECONFIG ??= "debounce dejitter evthres iir linear median pthres skip lowpass invert variance input touchkit waveshare" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 27 | PACKAGECONFIG[debounce] = "--enable-debounce,--disable-debounce" |
| 28 | PACKAGECONFIG[dejitter] = "--enable-dejitter,--disable-dejitter" |
Andrew Geissler | f103a7f | 2021-05-07 16:09:40 -0500 | [diff] [blame] | 29 | PACKAGECONFIG[evthres] = "--enable-evthres,--disable-evthres" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 30 | PACKAGECONFIG[iir] = "--enable-iir,--disable-iir" |
| 31 | PACKAGECONFIG[linear] = "--enable-linear,--disable-linear" |
| 32 | PACKAGECONFIG[median] = "--enable-median,--disable-median" |
| 33 | PACKAGECONFIG[pthres] = "--enable-pthres,--disable-pthres" |
| 34 | PACKAGECONFIG[skip] = "--enable-skip,--disable-skip" |
| 35 | PACKAGECONFIG[lowpass] = "--enable-lowpass,--disable-lowpass" |
| 36 | PACKAGECONFIG[invert] = "--enable-invert,--disable-invert" |
| 37 | PACKAGECONFIG[variance] = "--enable-variance,--disable-variance" |
| 38 | PACKAGECONFIG[input] = "--enable-input,--disable-input" |
| 39 | PACKAGECONFIG[tatung] = "--enable-tatung,--disable-tatung" |
| 40 | PACKAGECONFIG[touchkit] = "--enable-touchkit,--disable-touchkit" |
| 41 | PACKAGECONFIG[waveshare] = "--enable-waveshare,--disable-waveshare" |
| 42 | PACKAGECONFIG[ucb1x00] = "--enable-ucb1x00,--disable-ucb1x00" |
| 43 | PACKAGECONFIG[mk712] = "--enable-mk712,--disable-mk712" |
| 44 | PACKAGECONFIG[h3600] = "--enable-h3600,--disable-h3600" |
| 45 | PACKAGECONFIG[dmc] = "--enable-dmc,--disable-dmc" |
| 46 | PACKAGECONFIG[linear-h2200] = "--enable-linear-h2200,--disable-linear-h2200" |
| 47 | PACKAGECONFIG[corgi] = "--enable-corgi,--disable-corgi" |
| 48 | PACKAGECONFIG[collie] = "--enable-collie,--disable-collie" |
| 49 | PACKAGECONFIG[arctic2] = "--enable-arctic2,--disable-arctic2" |
| 50 | PACKAGECONFIG[dmc_dus3000] = "--enable-dmc_dus3000,--disable-dmc_dus3000" |
| 51 | PACKAGECONFIG[cy8mrln-palmpre] = "--enable-cy8mrln-palmpre,--disable-cy8mrln-palmpre" |
| 52 | PACKAGECONFIG[galax] = "--enable-galax,--disable-galax" |
Andrew Geissler | f103a7f | 2021-05-07 16:09:40 -0500 | [diff] [blame] | 53 | PACKAGECONFIG[one-wire-ts-input] = "--enable-one-wire-ts-input,--disable-one-wire-ts-input" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 54 | PACKAGECONFIG[debug] = "--enable-debug,--disable-debug" |
| 55 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 56 | do_install:prepend() { |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 57 | install -m 0644 ${WORKDIR}/ts.conf ${S}/etc/ts.conf |
| 58 | } |
| 59 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 60 | do_install:append() { |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 61 | install -d ${D}${sysconfdir}/profile.d/ |
| 62 | install -m 0755 ${WORKDIR}/tslib.sh ${D}${sysconfdir}/profile.d/ |
| 63 | } |
| 64 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 65 | RPROVIDES:tslib-conf = "libts-0.0-conf" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 66 | |
| 67 | PACKAGES =+ "tslib-conf tslib-tests tslib-calibrate tslib-uinput" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 68 | DEBIAN_NOAUTONAME:tslib-conf = "1" |
| 69 | DEBIAN_NOAUTONAME:tslib-tests = "1" |
| 70 | DEBIAN_NOAUTONAME:tslib-calibrate = "1" |
| 71 | DEBIAN_NOAUTONAME:tslib-uinput = "1" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 72 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 73 | RDEPENDS:${PN} = "tslib-conf" |
| 74 | RRECOMMENDS:${PN} = "pointercal" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 75 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 76 | FILES:${PN}-dev += "${libdir}/ts/*.la" |
| 77 | FILES:tslib-conf = "${sysconfdir}/ts.conf ${sysconfdir}/profile.d/tslib.sh ${datadir}/tslib" |
| 78 | FILES:${PN} = "${libdir}/*.so.* ${libdir}/ts/*.so*" |
| 79 | FILES:tslib-calibrate += "${bindir}/ts_calibrate" |
| 80 | FILES:tslib-uinput += "${bindir}/ts_uinput" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 81 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 82 | FILES:tslib-tests = "${bindir}/ts_harvest ${bindir}/ts_print ${bindir}/ts_print_raw ${bindir}/ts_print_mt \ |
Brad Bishop | 2f97392 | 2019-11-11 07:58:48 -0500 | [diff] [blame] | 83 | ${bindir}/ts_test ${bindir}/ts_test_mt ${bindir}/ts_verify ${bindir}/ts_finddev ${bindir}/ts_conf" |