Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 1 | require ttf.inc |
| 2 | |
| 3 | SUMMARY = "Liberation(tm) Fonts" |
| 4 | DESCRIPTION = "The Liberation(tm) Fonts is a font family originally \ |
| 5 | created by Ascender(c) which aims at metric compatibility with \ |
| 6 | Arial, Times New Roman, Courier New." |
| 7 | |
| 8 | HOMEPAGE = "https://fedorahosted.org/liberation-fonts/" |
| 9 | LICENSE = "GPLv2" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 11 | |
Brad Bishop | 7f28bc5 | 2017-12-03 23:42:40 -0500 | [diff] [blame] | 12 | SRC_URI = "https://releases.pagure.org/liberation-fonts/liberation-fonts-ttf-${PV}.tar.gz \ |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 13 | file://30-0-liberation-sans-narrow.conf \ |
| 14 | " |
| 15 | |
| 16 | SRC_URI[md5sum] = "134d8262145fc793c6af494dcace3e71" |
| 17 | SRC_URI[sha256sum] = "61a7e2b6742a43c73e8762cdfeaf6dfcf9abdd2cfa0b099a9854d69bc4cfee5c" |
| 18 | |
| 19 | S = "${WORKDIR}/liberation-fonts-ttf-${PV}" |
| 20 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 21 | do_install:append () { |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 22 | install -d ${D}${datadir}/fonts/TTF/ |
| 23 | install -d ${D}${sysconfdir}/fonts/conf.d/ |
| 24 | install -m 0644 LiberationSansNarrow*.ttf ${D}${datadir}/fonts/TTF/ |
| 25 | install -D -m 0644 ${WORKDIR}/30-0-liberation-sans-narrow.conf ${D}${sysconfdir}/conf.avail/30-${PN}-sans.conf |
| 26 | install -D -m 0644 ${S}/License.txt ${D}${datadir}/licenses/${PN}/LICENSE |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 27 | # normal liberation fonts come from ttf-liberation recipe so delete here |
| 28 | rm -rf ${D}${datadir}/fonts/truetype |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 29 | } |
| 30 | |
| 31 | PACKAGES = "${PN}" |
| 32 | FONT_PACKAGES = "${PN}" |
| 33 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 34 | FILES:${PN} = "${datadir}/fonts ${sysconfdir} ${datadir}/licenses" |