Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | require ${BPN}.inc |
| 2 | |
| 3 | DEPENDS = "zlib-native jpeg-native libpng-native libxext-native libxft-native" |
| 4 | |
| 5 | inherit native |
| 6 | |
| 7 | EXTRA_OECMAKE += " \ |
| 8 | -DOPTION_BUILD_SHARED_LIBS=OFF \ |
| 9 | -DOPTION_USE_THREADS=OFF \ |
| 10 | -DOPTION_USE_XDBE=OFF \ |
| 11 | -DOPTION_USE_XFT=OFF \ |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 12 | -DFLTK_BUILD_TEST=OFF \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 13 | -DOPTION_USE_XINERAMA=OFF \ |
| 14 | -DOPTION_USE_XFIXES=OFF \ |
| 15 | -DOPTION_USE_XCURSOR=OFF \ |
| 16 | " |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 17 | |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 18 | # lib/libfltk.a(Fl_Native_File_Chooser.cxx.o): undefined reference to symbol 'dlsym@@GLIBC_2.2.5' |
| 19 | LDFLAGS += "-ldl" |
| 20 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 21 | do_install:append() { |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 22 | # make sure native fltk-config is not used accidentaly |
| 23 | rm -f ${D}${bindir}/fltk-config |
| 24 | } |