Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Fast, multi-threaded malloc() and nifty performance analysis tools" |
| 2 | HOMEPAGE = "https://github.com/gperftools/gperftools" |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 3 | DESCRIPTION = "The gperftools, previously called google-perftools, package contains some \ |
| 4 | utilities to improve and analyze the performance of C++ programs. \ |
| 5 | Included are an optimized thread-caching malloc() and cpu and heap profiling utilities. \ |
| 6 | " |
| 7 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 8 | LICENSE = "BSD-3-Clause" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=762732742c73dc6c7fbe8632f06c059a" |
| 10 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 11 | DEPENDS:append:libc-musl = " libucontext" |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 12 | |
| 13 | SRCREV = "f7c6fb6c8e99d6b1b725e5994373bcd19ffdf8fd" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 14 | SRC_URI = "git://github.com/gperftools/gperftools \ |
| 15 | file://0001-Support-Atomic-ops-on-clang.patch \ |
| 16 | file://0001-fix-build-with-musl-libc.patch \ |
| 17 | file://0001-disbale-heap-checkers-and-debug-allocator-on-musl.patch \ |
| 18 | file://disable_libunwind_aarch64.patch \ |
| 19 | file://sgidef.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 20 | " |
| 21 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 22 | SRC_URI:append:libc-musl = " file://ppc-musl.patch" |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 23 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 24 | inherit autotools |
| 25 | |
| 26 | S = "${WORKDIR}/git" |
| 27 | |
| 28 | # On mips, we have the following error. |
| 29 | # do_page_fault(): sending SIGSEGV to ls for invalid read access from 00000008 |
| 30 | # Segmentation fault (core dumped) |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 31 | COMPATIBLE_HOST:mipsarch = "null" |
| 32 | COMPATIBLE_HOST:riscv64 = "null" |
| 33 | COMPATIBLE_HOST:riscv32 = "null" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 34 | |
| 35 | # Disable thumb1 |
| 36 | # {standard input}: Assembler messages: |
| 37 | # {standard input}:434: Error: lo register required -- `ldr pc,[sp]' |
| 38 | # Makefile:4538: recipe for target 'src/base/libtcmalloc_la-linuxthreads.lo' failed |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 39 | ARM_INSTRUCTION_SET:armv5 = "arm" |
| 40 | ARM_INSTRUCTION_SET:toolchain-clang:arm = "arm" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 41 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 42 | EXTRA_OECONF:append:libc-musl:powerpc64le = " --disable-cpu-profiler --disable-heap-profiler --disable-heap-checker" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 43 | PACKAGECONFIG ?= "libunwind static" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 44 | PACKAGECONFIG:remove:arm:libc-musl = "libunwind" |
| 45 | PACKAGECONFIG:remove:riscv64 = "libunwind" |
| 46 | PACKAGECONFIG:remove:riscv32 = "libunwind" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 47 | |
| 48 | PACKAGECONFIG[libunwind] = "--enable-libunwind,--disable-libunwind,libunwind" |
| 49 | PACKAGECONFIG[static] = "--enable-static,--disable-static," |
| 50 | |
| 51 | PACKAGE_BEFORE_PN += "libtcmalloc-minimal" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 52 | FILES:libtcmalloc-minimal = "${libdir}/libtcmalloc_minimal*${SOLIBS} ${libdir}/libtcmalloc_minimal_debug*${SOLIBS}" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 53 | |
| 54 | # pprof tool requires Getopt::long and POSIX perl5 modules. |
| 55 | # Also runs `objdump` on each cpuprofile data file |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 56 | RDEPENDS:${PN} += " \ |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 57 | binutils \ |
| 58 | curl \ |
| 59 | perl-module-carp \ |
| 60 | perl-module-cwd \ |
| 61 | perl-module-getopt-long \ |
| 62 | perl-module-overloading \ |
| 63 | perl-module-posix \ |
| 64 | " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 65 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 66 | RDEPENDS:${PN} += "libtcmalloc-minimal (= ${EXTENDPKGV})" |