Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Interactive process viewer" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 2 | HOMEPAGE = "https://htop.dev" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 3 | SECTION = "console/utils" |
| 4 | LICENSE = "GPLv2" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=4099d367cd5e59b6d4fc1ee33accb891" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 6 | |
| 7 | DEPENDS = "ncurses" |
| 8 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 9 | SRC_URI = "git://github.com/htop-dev/htop.git \ |
Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 10 | file://0001-Use-pkg-config.patch \ |
Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 11 | " |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame] | 12 | SRCREV = "ce6d60e7def146c13d0b8bca4642e7401a0a8995" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 13 | |
| 14 | S = "${WORKDIR}/git" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 15 | |
| 16 | inherit autotools pkgconfig |
| 17 | |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame] | 18 | PACKAGECONFIG ??= " \ |
| 19 | unicode \ |
| 20 | linux-affinity \ |
| 21 | delayacct \ |
| 22 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 23 | PACKAGECONFIG[openvz] = "--enable-openvz,--disable-openvz" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 24 | PACKAGECONFIG[vserver] = "--enable-vserver,--disable-vserver" |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame] | 25 | PACKAGECONFIG[ancient-vserver] = "--enable-ancient-vserver,--disable-ancient-vserver" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 26 | PACKAGECONFIG[unicode] = "--enable-unicode,--disable-unicode" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 27 | PACKAGECONFIG[hwloc] = "--enable-hwloc,--disable-hwloc,hwloc" |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame] | 28 | PACKAGECONFIG[linux-affinity] = "--enable-linux-affinity,--disable-linux-affinity" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 29 | PACKAGECONFIG[setuid] = "--enable-setuid,--disable-setuid" |
| 30 | PACKAGECONFIG[delayacct] = "--enable-delayacct,--disable-delayacct,libnl" |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame] | 31 | PACKAGECONFIG[sensors] = "--with-sensors,--without-sensors,lmsensors,lmsensors-libsensors" |
| 32 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 33 | FILES:${PN} += "${datadir}/icons/hicolor/scalable/apps/htop.svg" |
| 34 | |
| 35 | RDEPENDS:${PN} += "ncurses-terminfo-base" |